Bug 270607 - Kaffeine crashed after removing some channels and saying ok
Summary: Kaffeine crashed after removing some channels and saying ok
Status: RESOLVED FIXED
Alias: None
Product: kaffeine
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christoph Pfister
URL:
Keywords:
: 270798 271773 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-10 18:30 UTC by Markus Heer
Modified: 2011-05-04 16:07 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Heer 2011-04-10 18:30:19 UTC
Application: kaffeine (1.2.1)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.1-1.2-default i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
In Kaffeine folder TV, channels I removed some channels.
When I klick the ok- Button with my mouse, kaffeine crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: Kaffeine (kaffeine), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4fc69f0 (LWP 9842))]

Thread 2 (Thread 0xb1fffb70 (LWP 9852)):
#0  0xb560c22b in clock_gettime () from /lib/librt.so.1
#1  0xb6a91ae5 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6b64726 in updateCurrentTime (this=0xb2002974, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0xb2002974, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6b62f6b in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb1fff11c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6b6300d in timerSourcePrepare (source=0xb2002940, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb5556a70 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0xb55578e2 in ?? () from /lib/libglib-2.0.so.0
#9  0xb5557fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0xb6b637b7 in QEventDispatcherGlib::processEvents (this=0xb2000650, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb6b342bd in QEventLoop::processEvents (this=0xb1fff2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6b344e9 in QEventLoop::exec (this=0xb1fff2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6a357b9 in QThread::exec (this=0x8311798) at thread/qthread.cpp:490
#14 0xb6b1423d in QInotifyFileSystemWatcherEngine::run (this=0x8311798) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6a383aa in QThreadPrivate::start (arg=0x8311798) at thread/qthread_unix.cpp:285
#16 0xb69bcb05 in start_thread () from /lib/libpthread.so.0
#17 0xb5d4fd5e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb4fc69f0 (LWP 9842)):
[KCrash Handler]
#7  ref (this=0x8287c40, channel=...) at /usr/include/QtCore/qatomic_i386.h:120
#8  QExplicitlySharedDataPointer (this=0x8287c40, channel=...) at /usr/include/QtCore/qshareddata.h:164
#9  ExplicitlySharedDataPointer (this=0x8287c40, channel=...) at /usr/src/debug/kaffeine-1.2.1/src/shareddata.h:39
#10 DvbEpgEntry (this=0x8287c40, channel=...) at /usr/src/debug/kaffeine-1.2.1/src/dvb/dvbepg.h:34
#11 DvbEpgModel::channelRemoved (this=0x8287c40, channel=...) at /usr/src/debug/kaffeine-1.2.1/src/dvb/dvbepg.cpp:389
#12 0x08067073 in DvbEpgModel::qt_metacall (this=0x8287c40, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbf91ee58) at /usr/src/debug/kaffeine-1.2.1/build/src/moc_dvbepg.cpp:100
#13 0xb6b3b8cd in QMetaObject::metacall (object=0x8287c40, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf91ee58) at kernel/qmetaobject.cpp:237
#14 0xb6b4ba2c in QMetaObject::activate (sender=0x82502e0, m=0x8101410, local_signal_index=3, argv=0xbf91ee58) at kernel/qobject.cpp:3272
#15 0x08067a57 in DvbChannelModel::channelRemoved (this=0x82502e0, _t1=...) at /usr/src/debug/kaffeine-1.2.1/build/src/moc_dvbchannel.cpp:115
#16 0x08071b84 in DvbChannelModel::removeChannel (this=0x82502e0, channel=...) at /usr/src/debug/kaffeine-1.2.1/src/dvb/dvbchannel.cpp:464
#17 0x080727fc in DvbChannelModel::cloneFrom (this=0x82502e0, other=0x8c8ba70) at /usr/src/debug/kaffeine-1.2.1/src/dvb/dvbchannel.cpp:262
#18 0x080c9c0c in DvbScanDialog::dialogAccepted (this=0x8c85970) at /usr/src/debug/kaffeine-1.2.1/src/dvb/dvbscandialog.cpp:451
#19 0x080662ac in DvbScanDialog::qt_metacall (this=0x8c85970, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbf91f13c) at /usr/src/debug/kaffeine-1.2.1/build/src/moc_dvbscandialog.cpp:83
#20 0xb6b3b8cd in QMetaObject::metacall (object=0x8c85970, cl=QMetaObject::InvokeMetaMethod, idx=74, argv=0xbf91f13c) at kernel/qmetaobject.cpp:237
#21 0xb6b4ba2c in QMetaObject::activate (sender=0x8c85970, m=0xb69a1a64, local_signal_index=1, argv=0x0) at kernel/qobject.cpp:3272
#22 0xb6583a05 in QDialog::accepted (this=0x8c85970) at .moc/release-shared/moc_qdialog.cpp:145
#23 0xb6583ae8 in QDialog::done (this=0x8c85970, r=1) at dialogs/qdialog.cpp:597
#24 0xb65825da in QDialog::accept (this=0x8c85970) at dialogs/qdialog.cpp:610
#25 0xb72473b3 in KDialog::slotButtonClicked (this=0x8c85970, button=4) at /usr/src/debug/kdelibs-4.6.0/kdeui/dialogs/kdialog.cpp:884
#26 0xb7248cce in KDialog::qt_metacall (this=0x8c85970, _c=QMetaObject::InvokeMetaMethod, _id=33, _a=0xbf91f348) at /usr/src/debug/kdelibs-4.6.0/build/kdeui/kdialog.moc:190
#27 0x080661f3 in DvbScanDialog::qt_metacall (this=0x8c85970, _c=QMetaObject::InvokeMetaMethod, _id=69, _a=0xbf91f348) at /usr/src/debug/kaffeine-1.2.1/build/src/moc_dvbscandialog.cpp:77
#28 0xb6b3b8cd in QMetaObject::metacall (object=0x8c85970, cl=QMetaObject::InvokeMetaMethod, idx=69, argv=0xbf91f348) at kernel/qmetaobject.cpp:237
#29 0xb6b4ba2c in QMetaObject::activate (sender=0x8c886ec, m=0xb6c6e130, local_signal_index=0, argv=0xbf91f348) at kernel/qobject.cpp:3272
#30 0xb6b4fcf5 in QSignalMapper::mapped (this=0x8c886ec, _t1=4) at .moc/release-shared/moc_qsignalmapper.cpp:101
#31 0xb6b4ff69 in QSignalMapper::map (this=0x8c886ec, sender=0x8c7d7f8) at kernel/qsignalmapper.cpp:266
#32 0xb6b5007e in QSignalMapper::map (this=0x8c886ec) at kernel/qsignalmapper.cpp:257
#33 0xb6b50620 in QSignalMapper::qt_metacall (this=0x8c886ec, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbf91f4d8) at .moc/release-shared/moc_qsignalmapper.cpp:87
#34 0xb6b3b8cd in QMetaObject::metacall (object=0x8c886ec, cl=QMetaObject::InvokeMetaMethod, idx=8, argv=0xbf91f4d8) at kernel/qmetaobject.cpp:237
#35 0xb6b4ba2c in QMetaObject::activate (sender=0x8c7d7f8, m=0xb69aa824, local_signal_index=2, argv=0xbf91f4d8) at kernel/qobject.cpp:3272
#36 0xb67636cd in QAbstractButton::clicked (this=0x8c7d7f8, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:206
#37 0xb645e5ad in QAbstractButtonPrivate::emitClicked (this=0x8c7c180) at widgets/qabstractbutton.cpp:546
#38 0xb645fe8b in QAbstractButtonPrivate::click (this=0x8c7c180) at widgets/qabstractbutton.cpp:539
#39 0xb6460146 in QAbstractButton::mouseReleaseEvent (this=0x8c7d7f8, e=0xbf91fbf4) at widgets/qabstractbutton.cpp:1121
#40 0xb609c5b0 in QWidget::event (this=0x8c7d7f8, event=0xbf91fbf4) at kernel/qwidget.cpp:8200
#41 0xb645f160 in QAbstractButton::event (this=0x8c7d7f8, e=0xbf91fbf4) at widgets/qabstractbutton.cpp:1080
#42 0xb6501678 in QPushButton::event (this=0x8c7d7f8, e=0xbf91fbf4) at widgets/qpushbutton.cpp:683
#43 0xb6041414 in QApplicationPrivate::notify_helper (this=0x8153e08, receiver=0x8c7d7f8, e=0xbf91fbf4) at kernel/qapplication.cpp:4445
#44 0xb604ac20 in QApplication::notify (this=0xbf91f90c, receiver=0x8c7d7f8, e=0xbf91fbf4) at kernel/qapplication.cpp:4006
#45 0xb70cd1f1 in KApplication::notify (this=0xbf920460, receiver=0x8c7d7f8, event=0xbf91fbf4) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#46 0xb6b34fde in QCoreApplication::notifyInternal (this=0xbf920460, receiver=0x8c7d7f8, event=0xbf91fbf4) at kernel/qcoreapplication.cpp:732
#47 0xb604245c in sendSpontaneousEvent (receiver=0x8c7d7f8, event=0xbf91fbf4, alienWidget=0x8c7d7f8, nativeWidget=0x8c85970, buttonDown=0xb69b3c00, lastMouseReceiver=..., spontaneous=true) at ../../src/corelib/kernel/qcoreapplication.h:218
#48 QApplicationPrivate::sendMouseEvent (receiver=0x8c7d7f8, event=0xbf91fbf4, alienWidget=0x8c7d7f8, nativeWidget=0x8c85970, buttonDown=0xb69b3c00, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3103
#49 0xb60ce030 in QETWidget::translateMouseEvent (this=0x8c85970, event=0xbf92010c) at kernel/qapplication_x11.cpp:4438
#50 0xb60cd13e in QApplication::x11ProcessEvent (this=0xbf920460, event=0xbf92010c) at kernel/qapplication_x11.cpp:3442
#51 0xb60f7960 in x11EventSourceDispatch (s=0x8157140, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#52 0xb5557509 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#53 0xb5557d10 in ?? () from /lib/libglib-2.0.so.0
#54 0xb5557fce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#55 0xb6b6376b in QEventDispatcherGlib::processEvents (this=0x81335f8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#56 0xb60f755a in QGuiEventDispatcherGlib::processEvents (this=0x81335f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#57 0xb6b342bd in QEventLoop::processEvents (this=0xbf9203c4, flags=...) at kernel/qeventloop.cpp:149
#58 0xb6b344e9 in QEventLoop::exec (this=0xbf9203c4, flags=...) at kernel/qeventloop.cpp:201
#59 0xb6b38f90 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#60 0xb603f104 in QApplication::exec () at kernel/qapplication.cpp:3719
#61 0x080ed5dc in main (argc=0, argv=0x82aacec) at /usr/src/debug/kaffeine-1.2.1/src/main.cpp:79

This bug may be a duplicate of or related to bug 270531.

Possible duplicates by query: bug 270531, bug 267580, bug 263514, bug 261706, bug 257448.

Reported using DrKonqi
Comment 1 Christoph Pfister 2011-04-10 19:52:11 UTC
Git commit fa3506aa9d3418f08b2e3deae3c0fb829d9f4556 by Christoph Pfister.
Committed on 10/04/2011 at 19:48.
Pushed by pfister into branch 'master'.

eliminate use-after-delete cases

BUG: 270531
BUG: 270607

M  +2    -0    src/dvb/dvbchannel.cpp     
M  +2    -0    src/dvb/dvbrecording.cpp     

http://commits.kde.org/kaffeine/fa3506aa9d3418f08b2e3deae3c0fb829d9f4556
Comment 2 Christoph Feck 2011-04-13 05:06:50 UTC
*** Bug 270798 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Feck 2011-05-04 16:07:30 UTC
*** Bug 271773 has been marked as a duplicate of this bug. ***