Bug 269872 - GtkCombobox background is restored to non-transparent on configuration reparse
Summary: GtkCombobox background is restored to non-transparent on configuration reparse
Status: CLOSED FIXED
Alias: None
Product: Oxygen
Classification: Unclassified
Component: gtk2-engine (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Hugo Pereira Da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-01 13:17 UTC by Ruslan Kabatsayev
Modified: 2011-07-29 23:28 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ruslan Kabatsayev 2011-04-01 13:17:01 UTC
Version:           unspecified
OS:                Linux



Reproducible: Always

Steps to Reproduce:
1. Start cairo-clock.
2. Open config dialog, see combos looking ok.
3. Change color scheme via systemsettings.
4. See comboboxes getting white GtkCellView background.
Comment 1 Hugo Pereira Da Costa 2011-04-01 13:22:00 UTC
yes can reproduce.
Same with gtk-demo->comboboxes.
Comment 2 Hugo Pereira Da Costa 2011-04-01 13:40:32 UTC
Git commit 68e42eddc1b913a38966e6965a1db1c44e1e14e3 by Hugo Pereira Da Costa.
Committed on 01/04/2011 at 13:36.
Pushed by hpereiradacosta into branch 'master'.

update combobox cellview background color to transparent on style-set signal.

CCBUG: 269872

M  +6    -0    src/animations/oxygencomboboxdata.cpp     
M  +9    -1    src/animations/oxygencomboboxdata.h     

http://commits.kde.org/oxygen-gtk/68e42eddc1b913a38966e6965a1db1c44e1e14e3
Comment 3 Hugo Pereira Da Costa 2011-04-01 13:42:27 UTC
Fixed.
(that was easy, and the bug was actually a consequence of my removing "style-set" as a signal for unregistration, that was there in earlier versions of master, and is still there for 1.0).

Besides, I will not backport to 1.0 since there is no dbus support and hence no "on-fly" update there. 

So closing. 
Thanks for reporting.