Bug 269770 - Add Lanczos interpolation for scaling.
Summary: Add Lanczos interpolation for scaling.
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Tools/Transform (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR wishlist
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-30 16:15 UTC by animtim
Modified: 2013-01-05 16:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description animtim 2011-03-30 16:15:14 UTC
Version:           unspecified
OS:                Linux

Some people are asking to get Lanczos interpolation available for scaling.
This is a good idea as it seems to be a good one for this task.

Reproducible: Didn't try
Comment 1 Halla Rempt 2012-12-29 11:43:55 UTC
Well, actually we have a lanczos filter already, but it's disabled. I'm not totally sure why we disabled it though. Try to enable it in KisFilterStrategyRegistry* KisFilterStrategyRegistry::instance() and check whether it works?
Comment 2 Dmitry Kazakov 2013-01-05 16:09:51 UTC
Git commit 5be34e954863fd4b5d30246c9ee09f43b8f24e5f by Dmitry Kazakov.
Committed on 05/01/2013 at 17:08.
Pushed by dkazakov into branch 'master'.

Activate Lanczos3 filter

After fixing maths in the KisTransformWorker it works perfectly.

M  +1    -1    krita/image/kis_filter_strategy.cc

http://commits.kde.org/calligra/5be34e954863fd4b5d30246c9ee09f43b8f24e5f