Bug 269522 - KDM kills X during startup when time is changed
Summary: KDM kills X during startup when time is changed
Status: RESOLVED FIXED
Alias: None
Product: kdm
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdm bugs tracker
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-27 10:24 UTC by Szymon Świerkosz
Modified: 2011-06-11 18:41 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 4.6.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Szymon Świerkosz 2011-03-27 10:24:24 UTC
Version:           unspecified (using KDE 4.6.1) 
OS:                Linux

Clock in my computer was lagging behind about 40 minutes. When I start the computer it starts KDM and simultaneous ntp-client. When ntp-client synchronizes the time, KDM kills starting X with reason: timeout.

KDM should use a monotonic clock when possible instead of a wall clock.

I know, I just need to set my clock to a correct time (I did that and X is not killed anymore), but it took me a while to figure out the reason.

Reproducible: Always
Comment 1 Oswald Buddenhagen 2011-05-22 18:56:05 UTC
Git commit a38d29482cbada78f1ab9f894c871c4135cd8c17 by Oswald Buddenhagen.
Committed on 15/05/2011 at 12:19.
Pushed by ossi into branch 'KDE/4.6'.

use monotonic clock if available

this avoids that clock jumps (e.g., ntp syncs) cause timeouts.
(cherry picked from commit 858927c9d650697e8bd74697b8815c17cc93402d)

BUG: 269522
FIXED-IN: 4.6.4

M  +3    -0    kdm/backend/CMakeLists.txt     
M  +2    -2    kdm/backend/dm.c     
M  +11   -0    kdm/backend/dm.h     
M  +5    -3    kdm/backend/session.c     

http://commits.kde.org/kde-workspace/a38d29482cbada78f1ab9f894c871c4135cd8c17
Comment 2 Oswald Buddenhagen 2011-06-11 18:41:34 UTC
Git commit 9550608407aa72e77919a9ad1182f65cff0198cb by Oswald Buddenhagen.
Committed on 11/06/2011 at 18:28.
Pushed by ossi into branch 'KDE/4.6'.

use monotonic clock if available, take 2

BUG: 269522
FIXED-IN: 4.6.5

(cherry picked from commit a38d29482cbada78f1ab9f894c871c4135cd8c17)
(cherry picked from commit 7cec744e7f32da33c612288b4cffdf954ee12b06)
(cherry picked from commit 4ce1bda0decb3a5f3be9c4eed29154ae599fe14b)
(cherry picked from commit 42dbcf6de248231a430ff4199a324881ecedaa89)
(cherry picked from commit 17e305fb3e3aa8ed0048e2683b2a7a0a3506f9b6)

M  +3    -0    kdm/backend/CMakeLists.txt     
M  +10   -2    kdm/backend/ctrl.c     
M  +23   -2    kdm/backend/dm.c     
M  +12   -0    kdm/backend/dm.h     
M  +6    -3    kdm/backend/session.c     

http://commits.kde.org/kde-workspace/9550608407aa72e77919a9ad1182f65cff0198cb