Bug 269419 - Quicklaunch is overlapped by other widgets if panel gets too full [screenshot]
Summary: Quicklaunch is overlapped by other widgets if panel gets too full [screenshot]
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-quicklaunch (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Ingomar Wesp
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-25 22:24 UTC by Frank Steinmetzger
Modified: 2011-03-29 05:57 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Three degrees of overlapping of the Quicklaunch (52.34 KB, image/png)
2011-03-25 22:24 UTC, Frank Steinmetzger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Steinmetzger 2011-03-25 22:24:29 UTC
Created attachment 58339 [details]
Three degrees of overlapping of the Quicklaunch

Version:           unspecified (using KDE 4.6.1) 
OS:                Linux

I have a(n almost) typical bottom-panel layout:
+-------+-------------+------+-------+---------------+---------+------+-------+
| KMenu | Quicklaunch | Eyes | Pager | Taskbar       | Sysload | Tray | Clock |
+-------+-------------+------+-------+---------------+---------+------+-------+

When the taskbar gets too crowded, it pushes the pager out to the left, which then overlaps the quicklaunch. This should not happen for three reasons:

- buttons in the quicklaunch are not reachable because they are overlapped
- the position of other widgets (in my case the pager) change, so clicking on the same pixel on the pager may lead to switching back and forth between different desktops
- the taskbar automatically hides button texts if there is not enough space for both icon and text, but this kicks in too late, as it only shrinks them when it is already overfull.

In order to confirm that this as a quicklaunch bug I swapped its positions with the one of the taskbar. This time it was pushed to the right and the Quicklaunch’s right edge overlapped the widget right of it.

I remember that in earlier versions the icon spacing was dynamic, depending on available space. Now the spacing is constant again (which I like better BTW), but apparently Quicklaunch is still reporting the smaller size hint.

Reproducible: Always
Comment 1 Ingomar Wesp 2011-03-26 13:46:56 UTC
Thanks for the excellent bug report. I can reproduce the issue and hope that I’ll be able to look into it soon. Unfortunately, I haven’t been able to divert any time to KDE due to university work lately, but that’ll change soon.

> I remember that in earlier versions the icon spacing was dynamic, depending on
> available space. Now the spacing is constant again (which I like better BTW),
> but apparently Quicklaunch is still reporting the smaller size hint.

It’s a bit more complicated than that, unfortunately. The applet doesn’t set a proper minimum size hint at all (the reason is a bit technical and has to do with how this would cause trouble with multi-row wrapping and user resizing in the desktop containment). I’ll look into it.
Comment 2 Ingomar Wesp 2011-03-29 05:47:25 UTC
Git commit 284de0012485b01defc73bde121d1b918ee75615 by Ingomar Wesp.
Committed on 29/03/2011 at 05:26.
Pushed by iwesp into branch 'master'.

Provide a proper minimumSize hint (preferredWidth for horizontal form factors,
preferredHeight for vertical ones).

CCBUG: 264606
CCBUG: 269419

M  +7    -1    plasma/generic/applets/quicklaunch/icongridlayout.cpp     
M  +1    -1    plasma/generic/applets/quicklaunch/plasma-applet-quicklaunch.desktop     

http://commits.kde.org/kde-workspace/284de0012485b01defc73bde121d1b918ee75615
Comment 3 Ingomar Wesp 2011-03-29 05:52:27 UTC
Git commit 6b033466e0ce885eea3715eae70d7c08bac0bb4c by Ingomar Wesp.
Committed on 29/03/2011 at 05:54.
Pushed by iwesp into branch 'KDE/4.6'.

Backport to 4.6: Provide a proper minimumSize hint (preferredWidth for
horizontal form factors, preferredHeight for vertical ones).

CCBUG: 264606
CCBUG: 269419

M  +7    -1    plasma/generic/applets/quicklaunch/icongridlayout.cpp     
M  +1    -2    plasma/generic/applets/quicklaunch/plasma-applet-quicklaunch.desktop     

http://commits.kde.org/kde-workspace/6b033466e0ce885eea3715eae70d7c08bac0bb4c
Comment 4 Ingomar Wesp 2011-03-29 05:57:13 UTC
Turn out this was easier than I thought. Should be fixed in master and the 4.6 branch now.