Bug 269045 - validate .desktop files
Summary: validate .desktop files
Status: RESOLVED FIXED
Alias: None
Product: kmplayer
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: RedHat Enterprise Linux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-21 15:11 UTC by Rex Dieter
Modified: 2014-12-20 18:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 4.14.4


Attachments
suggseted patch (5.79 KB, patch)
2011-03-21 15:11 UTC, Rex Dieter
Details
suggested patch (5.95 KB, patch)
2011-03-21 19:49 UTC, Rex Dieter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rex Dieter 2011-03-21 15:11:23 UTC
Created attachment 58212 [details]
suggseted patch 

Version:           unspecified (using KDE 4.6.1) 
OS:                Linux

.desktop files shipped in 0.11.2c fail using desktop-file-validate, among the errors include invalid mimetypes:

Error in file "/usr/share/applications/kde4/kmplayer.desktop": "uri/mms" is an
invalid MIME type ("uri" is an unregistered media type)
Error in file "/usr/share/applications/kde4/kmplayer.desktop": "uri/pnm" is an
invalid MIME type ("uri" is an unregistered media type)
Error in file "/usr/share/applications/kde4/kmplayer.desktop": "uri/rtspt" is
an invalid MIME type ("uri" is an unregistered media type)
Error in file "/usr/share/applications/kde4/kmplayer.desktop": "uri/rtspu" is
an invalid MIME type ("uri" is an unregistered media type)

missing "Player" category, and invalid locales.

Reproducible: Always
Comment 1 Rex Dieter 2011-03-21 19:49:27 UTC
Created attachment 58224 [details]
suggested patch

last one missed adding "Player" to Categories
Comment 2 Koos Vriezen 2011-03-21 20:34:09 UTC
Looks fine to me. I think those uri/* mimetypes were valid in KDE3, where one could register for a certain protocol too.
Comment 3 Koos Vriezen 2011-03-21 21:28:23 UTC
SVN commit 1225583 by vriezen:

Remove uri/xxx mimetypes and x-test language

Patch from Rex Dieter

BUG:269045

 M  +2 -5      kmplayer.desktop   [TRAILING SPACE]
 M  +1 -3      kmplayer_part.desktop  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1225583
Comment 4 Rex Dieter 2011-03-21 21:46:08 UTC
I was reminded on irc that indeed the uri mimetypes are defined in kde.xml (in kdelibs).  This probably ought to be fixed differently than just dropping them here then.  I'll try to investigate the options.
Comment 5 Rex Dieter 2011-03-21 21:46:54 UTC
Oh, and the [x-test] locale entries will get re-added by scripty anyway.
Comment 6 Rex Dieter 2011-03-21 22:01:34 UTC
Ok, will likely have to take a similar approach as
http://svn.reviewboard.kde.org/r/6111/
Comment 7 Koos Vriezen 2011-03-22 21:52:12 UTC
Just let me know whether I should revert the uri/* removal. Looking at the file association configuration in konquerors settings, I think I indeed should.
Comment 8 Rex Dieter 2011-03-23 19:29:39 UTC
Yeah, I'd say revert it for now, pending a "proper" fix, sorry for the hassle here.
Comment 9 Rex Dieter 2011-04-25 20:27:17 UTC
Wow, looks like the origin's of these mimetypes go all the way back to:
http://lists.freedesktop.org/archives/xdg/2010-October/011629.html
http://websvn.kde.org/?view=revision&revision=380464

It's been suggested we try to use the
x-scheme-handler/...
type referenced here,
http://lists.freedesktop.org/archives/xdg/2010-October/011629.html
instead, which seems like a fit to me.
Comment 10 Rex Dieter 2011-04-25 20:50:14 UTC
https://git.reviewboard.kde.org/r/101231/
Comment 11 Rex Dieter 2011-04-25 21:06:59 UTC
SVN commit 1229117 by rdieter:

restore mimetypes removed in r1225583 as x-scheme-handler/ instead

CCBUG: 269045


 M  +1 -1      kmplayer.desktop  
 M  +1 -1      kmplayer_part.desktop  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1229117
Comment 12 Rex Dieter 2014-12-18 14:18:56 UTC
Finally got annoyed enough to update reviewboard, see
https://git.reviewboard.kde.org/r/101231/
for fresh proposed patch.
Comment 13 Rex Dieter 2014-12-20 18:12:38 UTC
Git commit 8e7c42a1da9d4abd7cb1d3a895f9884366beced7 by Rex Dieter.
Committed on 18/12/2014 at 13:58.
Pushed by rdieter into branch 'KDE/4.14'.

kill references to old uri/ style fake mimetypes
FIXED-IN: 4.14.4
REVIEW: 101231

M  +0    -1    kio/misc/mms.protocol
M  +0    -1    kio/misc/mmst.protocol
M  +0    -1    kio/misc/mmsu.protocol
M  +0    -1    kio/misc/pnm.protocol
M  +0    -1    kio/misc/rtspt.protocol
M  +0    -1    kio/misc/rtspu.protocol
M  +0    -344  mimetypes/kde.xml

http://commits.kde.org/kdelibs/8e7c42a1da9d4abd7cb1d3a895f9884366beced7