Bug 268476 - Wikipedia widget fails when going back to an article with an ampersand (&) in its name
Summary: Wikipedia widget fails when going back to an article with an ampersand (&) in...
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Context View/Wikipedia (show other bugs)
Version: 2.5-git
Platform: Ubuntu Packages Linux
: NOR minor (vote)
Target Milestone: 2.4.1
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-14 16:17 UTC by Alvaro Manuel Recio Perez
Modified: 2012-01-03 11:10 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alvaro Manuel Recio Perez 2011-03-14 16:17:04 UTC
Version:           2.4.0 (using KDE 4.6.1) 
OS:                Linux

The Wikipedia widget correctly shows pages with an ampersand in its title (&). However, clicking the back button after following a link tries to load an article with its title truncated at the ampersand.

Reproducible: Always

Steps to Reproduce:
1. Play a song from an artist with "&" in its name (I tested it with "Beyond Good & Evil Soundtrack).
2. Click a link in the Wikipedia widget.
3. Press the "back" button.

Actual Results:  
4. The Wikipedia widget tries to return to an article with its name truncated (in my case "Beyond Good".

Expected Results:  
The widget should correctly return to the previous article.

OS: Linux (x86_64) release 2.6.35-27-generic
Compiler: cc
Comment 1 Myriam Schweingruber 2011-06-04 12:16:48 UTC
This is an automated message from the triager:

Amarok 2.4.1 has been released on May 8 already. Could you please upgrade and test if you can still reproduce this bug?

Without feedback within a month we will close this bug as resolved.

Thank you for your understanding.
Comment 2 Alvaro Manuel Recio Perez 2011-06-07 13:21:10 UTC
Yes, the bug is still reproducible in Amarok 2.4.1.
Comment 3 Myriam Schweingruber 2011-06-07 23:21:49 UTC
Thank you for your feedback.
Comment 4 Sven Krohlas 2011-11-29 14:59:54 UTC
Also other characters like "+" are problematic. They seem to stay in the url and are not being percent encoded. But it seems to be more complicated to fix than it sounds...
Comment 5 Rick W. Chen 2011-12-05 03:44:44 UTC
Hmm, just tried it here with "Francis Albert Sinatra & Antonio Carlos Jobim".
It works (back and forward).

Are you running qt 4.8?
Comment 6 Sven Krohlas 2011-12-05 09:16:53 UTC
I recently upgraded from 4.7.x to 4.8 beta, same behaviour:

1. Artist: "Mike & the Mechanics"
2. Applet shows article: "Mike + The Mechanics"
3. click on "English" in the article text
4. Applet shows article "England"
5. clicking back: Applet shows article "Mike The Mechanics" (which does not exist)
Comment 7 Rick W. Chen 2011-12-06 08:24:37 UTC
(In reply to comment #6)

I still can't reproduce the problem.

1. Electric guitar
2. Mike + The Mechanics
3. England (English)

hitting back arrow

4. (2)
5. (1)

Not sure why in your case you get "Mike The Mechanics" at step 5.
Anyway it's probably a url/encoding/conversion issue. Possible fix
coming.
Comment 8 Rick W. Chen 2011-12-06 08:27:33 UTC
Git commit a289d8b1120d848e716235ae16dae9f6bad1a7de by Rick W. Chen.
Committed on 06/12/2011 at 09:27.
Pushed by rickc into branch 'master'.

Make sure url is encoded when converting wikipedia click urls

CCBUG: 268476

M  +1    -1    src/context/engines/wikipedia/WikipediaEngine.cpp

http://commits.kde.org/amarok/a289d8b1120d848e716235ae16dae9f6bad1a7de
Comment 9 Myriam Schweingruber 2012-01-03 11:10:08 UTC
Closing correctly.