Bug 268007 - Krita error when trying to save jpg image
Summary: Krita error when trying to save jpg image
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: File formats (show other bugs)
Version: 2.2
Platform: Ubuntu Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
: 270701 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-08 21:36 UTC by Marcelo Escobal
Modified: 2011-09-01 12:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
example of JPG that raises an error in Krita (could be any of my JPG files) (87.48 KB, image/jpeg)
2011-03-09 03:34 UTC, Marcelo Escobal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcelo Escobal 2011-03-08 21:36:53 UTC
Version:           2.2 (using KDE 4.5.1) 
OS:                Linux

Sometimes, when I try to save a jpg image it shows me the export window, then an error mesage saying it can't save the image. If I open a png image, the error doesn't appear and I can save normally.

Reproducible: Sometimes

Steps to Reproduce:
Open a JPG, modify the image, save it.

Actual Results:  
Error message saying it cannot save the image.

Expected Results:  
Save modified image in JPG format.
Comment 1 Sven Langkamp 2011-03-09 03:05:33 UTC
Could you provide a file that fails to save?
Comment 2 Marcelo Escobal 2011-03-09 03:34:48 UTC
Created attachment 57790 [details]
example of JPG that raises an error in Krita (could be any of my JPG files)
Comment 3 Marcelo Escobal 2011-03-09 03:38:57 UTC
Additional information:

When launching Krita there's an error message:

Error al ejectuar 
/usr/share/applications/kde4/krita.desktop.
Es probable que KLauncher no esté en ejecución, o que haya fallado al iniciar la aplicación.

Something like:
"Error running /usr/.../krita.desktop. Probably KLauncher isn't running or failed launching the application".

I open a file like the one attached, and when trying to save with another name, appears:

No se puede guardar
/home/mescobal/Imágenes/Documentos/teoria y practica3.jpeg

"Can't save /home....."
Comment 4 Sven Langkamp 2011-03-09 03:54:38 UTC
Confirmed. Problem isn't the file, but the special character in the path.
Comment 5 Marcelo Escobal 2011-03-09 04:13:34 UTC
I thought the application used KDE libraries to parse the path !
Thanks a lot. I really like KOffice (or whatever name it has now) and I'll give it many shots before quitting. Thanks for the speed in the response (not seen when I was using other DEs).
Comment 6 Sven Langkamp 2011-04-11 19:21:39 UTC
*** Bug 270701 has been marked as a duplicate of this bug. ***
Comment 7 Gatoso 2011-04-11 19:45:29 UTC
I have reported this bug https://bugs.kde.org/show_bug.cgi?id=270701 marked as a duplicate of this bug

The problem too occurs when the folder where you want to save the edited jpg images has in their name the spanish letter ñ
Comment 8 Gatoso 2011-04-11 21:00:40 UTC
Cyrillic letters too produces the error:

ё":ъяшертыуиопющэасдфгчйкльжзхцвбнм
Comment 9 Cyrille Berger 2011-04-16 15:23:34 UTC
Git commit 4e08b8e2d12d0333b17a9a9c3b6be0d5e56c22dd by Cyrille Berger.
Committed on 16/04/2011 at 15:28.
Pushed by berger into branch 'master'.

Fix: saving jpg/png when using non-ascii filename

CCBUG:268007

M  +1    -1    krita/plugins/formats/gif/gif_converter.cpp     
M  +1    -1    krita/plugins/formats/jpeg/kis_jpeg_converter.cc     

http://commits.kde.org/calligra/4e08b8e2d12d0333b17a9a9c3b6be0d5e56c22dd
Comment 10 Marcelo Escobal 2011-04-16 15:45:39 UTC
Thanks a lot. I really appreciate the effort from the KDE/Koffice/Community people. In less than a month! That's one if the reasons I keep using KDE and QT-related software. And the lack of response was the reason I left the previous DE. 
Again: thanks.
Comment 11 Sven Langkamp 2011-09-01 12:09:48 UTC
Works here now with german special characters.