Bug 267234 - Troubles with tabbar Highlight feature
Summary: Troubles with tabbar Highlight feature
Status: RESOLVED FIXED
Alias: None
Product: rekonq
Classification: Applications
Component: general (show other bugs)
Version: latest git snapshot
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: 0.9
Assignee: Andrea Diamantini
URL:
Keywords:
: 267060 267710 268686 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-27 11:04 UTC by Andrea Diamantini
Modified: 2012-01-20 11:38 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
rekonq tabbar problems image (14.75 KB, image/jpeg)
2011-03-03 17:10 UTC, Andrea Diamantini
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrea Diamantini 2011-02-27 11:04:03 UTC
Version:           latest git snapshot
OS:                Linux

Here to collect all the troubles against tabbar highlight new feature. You should basically notice problems like the ones in the screenshots.
Please, add yourself here just if you are having these troubles with rekonq 0.6.85 or superior.
And please, report the following:
- rekonq VERSION
- KDE SC VERSION
- Qt VERSION (say also if you use the graphics system "raster" enabled by default)
- X11 driver & graphics board (eg: mine is intel GM965 with xf86-video-intel-2.14.0)


Reproducible: Didn't try
Comment 1 Felix Rohrbach 2011-02-27 14:54:04 UTC
Having this problem with:

rekonq: 0.6.85
KDE: 4.6.0
Qt: 4.7.1 (I guess with raster, as I did not change anything)
X11: NVidia Geforce 9600 GT with nvidia driver (260.19.36)
OS: ArchLinux

(btw, which screenshot?)
Comment 2 Felix Rohrbach 2011-02-27 15:46:40 UTC
*** Bug 267060 has been marked as a duplicate of this bug. ***
Comment 3 Giulio Guzzinati 2011-02-27 16:19:52 UTC
rekonq:        git 0.6.85+
KDE SC:        4.6.0
Qt:        4.7.1 (IIRC raster)
X11:        Nvidia GeForce 9400 M/GS with nvidia proprietary
OS:        Arch i686
Comment 4 Kilian Lackhove 2011-02-27 16:45:20 UTC
rekonq:   git 4.6.85
KDE:      4.6.0
Qt:       4.7.1 (raster)
X11:      NVIDIA Geforce 6600 proprietary 260.19.36-2
OS:       archlinux amd64

bug occurs everytime i visit ars technica


and my other PC

rekonq:  git 0.6.81+
KDE:     4.6.0
Qt:      4.7.0-0ubuntu4.2 echo $QT_GRAPHICSSYSTEM shows nothing
X11:     Some ati mobile card, radeon 6.13.1 driver
OS:      Kubuntu maverick 32bit

bug occurs only sometimes and randomly
Comment 5 Cédric Bellegarde 2011-03-02 13:40:37 UTC
https://bugs.kde.org/show_bug.cgi?id=267312

Seems similar to this one, do my commit fix your issue ?
Comment 6 Cédric Bellegarde 2011-03-02 14:05:51 UTC
Can confirm this bug isn't fixed by my commit :-(
Comment 7 Andrea Diamantini 2011-03-03 17:10:08 UTC
(In reply to comment #1)
> (btw, which screenshot?)
oops... I was sure to have had pushed it... :D
Comment 8 Andrea Diamantini 2011-03-03 17:10:41 UTC
Created attachment 57645 [details]
rekonq tabbar problems image
Comment 9 Panagiotis Papadopoulos 2011-03-06 17:42:22 UTC
*** Bug 267710 has been marked as a duplicate of this bug. ***
Comment 10 Panagiotis Papadopoulos 2011-03-06 17:45:07 UTC
rekonq:        git 0.6.85+
KDE SC:        4.6.1
Qt:        4.7.2 (raster)
X11:        Nvidia GeForce GT320 M with nvidia proprietary drivers
OS:        Arch Linux x86_64
Comment 11 Giulio Guzzinati 2011-03-08 14:29:27 UTC
Perhaps I might have found a way to trigger the bug!
When I open this page:

http://kde-apps.org/content/show.php/KBibTeX?content=27421

I am asked if I want to save a file named "safari.jsp"
When i close the file saving dialog the bug has appeared, and any tab I open is corrupted.
Comment 12 Andrea Diamantini 2011-03-13 16:31:13 UTC
Git commit ae58104b91693b0b1d7404b5fe7600d6c157a5ce by Andrea Diamantini.
Committed on 13/03/2011 at 16:29.
Pushed by adjam into branch 'master'.

This commit to try fixing all troubles against the tabbar highlight feature.

Courtesy fix patch from the man implementing the feature: Johannes Troscher.
Many Thanks for.

Bug Reporters: please, let us know if this really fix it!

CCBUG:267234

M  +8    -0    src/tabbar.cpp     
M  +2    -0    src/tabbar.h     

http://commits.kde.org/rekonq/ae58104b91693b0b1d7404b5fe7600d6c157a5ce
Comment 13 Felix Rohrbach 2011-03-13 17:28:09 UTC
For me, the problem still exists. The link given above still triggers the bug.
Comment 14 Andrea Diamantini 2011-03-13 21:37:36 UTC
(In reply to comment #13)
> For me, the problem still exists. The link given above still triggers the bug.

The kde-apps one?
Comment 15 Felix Rohrbach 2011-03-13 22:11:54 UTC
(In reply to comment #14)
> (In reply to comment #13)
> > For me, the problem still exists. The link given above still triggers the bug.
> 
> The kde-apps one?
yes
Comment 16 Kilian Lackhove 2011-03-14 20:30:59 UTC
when visiting the kde-apps links i dont get the download dialog anymore. But when i browse to ther sites, the tabbar bug stil appears.
Comment 17 Xavier Corredor Llano 2011-03-15 16:59:37 UTC
with rekonq-git version (2011-03-15), the problem still exists for me too.

for example, always happens when open gmail (with chat) or youtube.

using display driver: i915
Comment 18 Felix Rohrbach 2011-03-16 21:51:07 UTC
*** Bug 268686 has been marked as a duplicate of this bug. ***
Comment 19 Andrea Diamantini 2011-03-17 00:07:16 UTC
Git commit 15215cf154c7d31f1520c259529b719b1fe84b48 by Andrea Diamantini.
Committed on 16/03/2011 at 23:48.
Pushed by adjam into branch 'master'.

Set an option to disable the disable graphics effects on the tabbar
highlight animation.

CCBUG:267234

To see if this really works, please deselect the "animated tab highlights"
in the Tabs Settings section

M  +2    -0    src/application.cpp     
M  +3    -0    src/rekonq.kcfg     
M  +7    -0    src/settings/settings_tabs.ui     
M  +54   -21   src/tabbar.cpp     
M  +1    -0    src/tabbar.h     

http://commits.kde.org/rekonq/15215cf154c7d31f1520c259529b719b1fe84b48
Comment 20 Xavier Corredor Llano 2011-03-17 05:44:04 UTC
I tested and fix for me, but I think this options should be disabled for default.

thanks Andrea Diamantini :)
Comment 21 Andrea Diamantini 2011-03-17 21:17:36 UTC
(In reply to comment #20)
> I tested and fix for me, but I think this options should be disabled for
> default.
> 
> thanks Andrea Diamantini :)

This "fix" comes with a six hands work. So thanks also to Felix Rohrbach and Johanner Troscher. 
About disabling it by default... I thought to not do it cause of it seems this only happens regularly just on nvidia cards.
I will take care to explain it in the release announcement.

Leaving this bug ASSIGNED to ne really sure this is just a graphics card problem...
Comment 22 Ezio Vergine 2011-03-20 13:00:07 UTC
Before the patch work fine!
thanks!

Qt: 4.7.0 (raster)
KDE Development Platform: 4.6.1 (4.6.1)
rekonq: 0.6.89
X11:        Nvidia 8400 M with nvidia proprietary drivers (270.29)
OS:        kubuntu 10.10
Comment 23 Andrea Diamantini 2011-03-21 22:36:25 UTC
Git commit 8946eecd22b4810dea452dafa4e0e2f8e55c573c by Andrea Diamantini.
Committed on 21/03/2011 at 22:26.
Pushed by adjam into branch 'master'.

Workaround the troubles with the tabbar highlight feature.

Another fantastic patch by Johannes Trosher. Thanks :)

CCBUG:267234

M  +6    -1    src/mainview.cpp     
M  +5    -10   src/tabbar.cpp     
M  +0    -1    src/tabbar.h     
M  +3    -0    src/tabhighlighteffect.cpp     

http://commits.kde.org/rekonq/8946eecd22b4810dea452dafa4e0e2f8e55c573c
Comment 24 Xavier Corredor Llano 2011-03-28 17:36:30 UTC
with the last commit the highlight feature is work for my :), I don't need disable it. 

can consider the option of remove the CheckBox in preferences.
Comment 25 Shaun Hunter 2011-08-21 23:25:20 UTC
This bug is still present in rekonq 0.7.57 (from the rekonq ppa for ubuntu) and is always reproducable.

KDE 4.7.0
Kubuntu 11.04 64 bit
ATI Radeon HD3870 
ATI Catalyst driver 10.2
Comment 26 Andrea Diamantini 2012-01-03 17:33:48 UTC
What about now? Does this work well with rekonq 0.8.1?
Comment 27 Shaun Hunter 2012-01-03 20:39:23 UTC
This bug seems to be fixed in rekonq 0.8.56 (from the rekonq ppa for ubuntu)
Thanks!

KDE 4.7.4
Kubuntu 11.10 64 bit
ATI Radeon HD3870
ATI Catalyst driver 10.12


On Tue, Jan 3, 2012 at 11:33 AM, Andrea Diamantini <adjam7@gmail.com> wrote:

> https://bugs.kde.org/show_bug.cgi?id=267234
>
>
>
>
>
> --- Comment #26 from Andrea Diamantini <adjam7 gmail com>  2012-01-03 17:33:48
> ---
> What about now? Does this work well with rekonq 0.8.1?
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
>
Comment 28 Andrea Diamantini 2012-01-04 10:47:23 UTC
Thanks Shaun. Waiting for other confirms to set this as fixed. Anyway, I think changes happen just in Qt libs and in video drivers... ;)
Comment 29 Andrea Diamantini 2012-01-20 11:38:26 UTC
We fixed the part we are responsible. Other occasional troubles could happen with old qt libs or driver versions