Bug 266530 - [PATCH] Make tabs in the Tabify plugin movable
Summary: [PATCH] Make tabs in the Tabify plugin movable
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 264788 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-17 16:14 UTC by Alex Smith
Modified: 2011-08-30 14:51 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Patch (3.46 KB, patch)
2011-02-17 16:15 UTC, Alex Smith
Details
Line number updated for kate-4.6.2 (3.14 KB, patch)
2011-04-14 08:16 UTC, Tao Bao
Details
make tabs movable and keep the moved positions on reopening (5.54 KB, patch)
2011-04-23 05:50 UTC, Tao Bao
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Smith 2011-02-17 16:14:57 UTC
Version:           unspecified (using Devel) 
OS:                Linux

This patch enables tabs in the Tabify plugin for Kate to be moved around into whatever order the user wants.

Reproducible: Always
Comment 1 Alex Smith 2011-02-17 16:15:25 UTC
Created attachment 57328 [details]
Patch
Comment 2 Tao Bao 2011-04-14 08:16:15 UTC
Created attachment 58941 [details]
Line number updated for kate-4.6.2

It is identical to the first attachment except for the line numbers.
Comment 3 Tao Bao 2011-04-14 08:17:46 UTC
(In reply to comment #1)
> Created an attachment (id=57328) [details]
> Patch

It works great! Thanks!
Comment 4 Dominik Haumann 2011-04-14 20:35:26 UTC
Git commit 70ed2aeb54c141f4833dc343ea02c530abba0b71 by Dominik Haumann.
Committed on 14/04/2011 at 20:40.
Pushed by dhaumann into branch 'master'.

Tabify plugin: make tabs movable

Thanks to Alex Smith for the initial patch!
BUG: 266530

M  +26   -9    kate/plugins/tabify/tabify.cpp     
M  +3    -0    kate/plugins/tabify/tabify.h     

http://commits.kde.org/kate/70ed2aeb54c141f4833dc343ea02c530abba0b71
Comment 5 Tao Bao 2011-04-23 05:50:23 UTC
Created attachment 59227 [details]
make tabs movable and keep the moved positions on reopening

The patch follows the last patch by Alex Smith. In last patch, the moved positions are kept locally in m_docList, which will be lost after exiting. With this updated patch, it also changes the order of document list maintained by Kate's document manager. So that documents (and tabs) will be listed according to their latest positions on reopening.
Comment 6 Dominik Haumann 2011-04-25 11:31:41 UTC
Can you open a new report for that with the patch? This one is closed already.
Comment 7 Dominik Haumann 2011-08-30 14:51:27 UTC
*** Bug 264788 has been marked as a duplicate of this bug. ***