Bug 266483 - Crash when tonal mapping image
Summary: Crash when tonal mapping image
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-16 18:46 UTC by Thomas Guymer
Modified: 2011-02-26 18:36 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Guymer 2011-02-16 18:46:59 UTC
Application: krita (2.1.2)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.7-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
I tried to tonal map a 16bit TIFF and it crashes when I clicked "Apply".

 -- Backtrace:
Application: Krita (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ff6c1eec760 (LWP 8942))]

Thread 2 (Thread 0x7ff69a80b710 (LWP 8944)):
#0  0x00007ff6bf008e13 in select () from /lib64/libc.so.6
#1  0x00007ff6c05ba711 in qt_safe_select(int, fd_set*, fd_set*, fd_set*, timeval const*) () from /usr/lib64/libQtCore.so.4
#2  0x00007ff6c05bf53b in QEventDispatcherUNIXPrivate::doSelect(QFlags<QEventLoop::ProcessEventsFlag>, timeval*) () from /usr/lib64/libQtCore.so.4
#3  0x00007ff6c05c08af in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007ff6c0594292 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007ff6c0594495 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007ff6c04ab2cf in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007ff6c04adbf5 in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007ff6b656fae3 in ?? () from /usr/X11R6/lib64/libGL.so.1
#9  0x00007ff6c021fa4f in start_thread () from /lib64/libpthread.so.0
#10 0x00007ff6bf00f82d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff6c1eec760 (LWP 8942)):
[KCrash Handler]
#5  0x00007ff6b004fa86 in KoColorSpace::operator==(KoColorSpace const&) const () from /usr/lib64/libpigmentcms.so.6
#6  0x00007ff68eff5e7c in KisToneMappingDialog::apply (this=0x594e6c0) at /usr/src/debug/koffice-2.1.2/krita/plugins/extensions/tonemapping/kis_tonemapping_dialog.cc:89
#7  0x00007ff68eff80ac in KisToneMappingDialog::qt_metacall (this=0x594e6c0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff3656c0e0)
    at /usr/src/debug/koffice-2.1.2/build/krita/plugins/extensions/tonemapping/kis_tonemapping_dialog.moc:80
#8  0x00007ff6c05a8a1f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#9  0x00007ff6bfb0a72e in QAbstractButtonPrivate::emitPressed (this=<value optimized out>) at widgets/qabstractbutton.cpp:560
#10 0x00007ff6bfb0b1ac in QAbstractButton::mousePressEvent (this=0x82077b0, e=0x7fff3656ca60) at widgets/qabstractbutton.cpp:1096
#11 0x00007ff6bf7ba0a9 in QWidget::event (this=0x82077b0, event=0x7fff3656ca60) at kernel/qwidget.cpp:8040
#12 0x00007ff6bf7694d4 in QApplicationPrivate::notify_helper (this=0x6c5420, receiver=0x82077b0, e=0x7fff3656ca60) at kernel/qapplication.cpp:4302
#13 0x00007ff6bf77234a in QApplication::notify (this=<value optimized out>, receiver=0x82077b0, e=0x7fff3656ca60) at kernel/qapplication.cpp:3867
#14 0x00007ff6c0a20c06 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#15 0x00007ff6c0594e4c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#16 0x00007ff6bf76b1e5 in sendEvent (receiver=0x82077b0, event=0x7fff3656ca60, alienWidget=0x82077b0, nativeWidget=0x594e6c0, buttonDown=0x7ff6c0215b28, lastMouseReceiver=..., spontaneous=true)
    at ../../src/corelib/kernel/qcoreapplication.h:215
#17 QApplicationPrivate::sendMouseEvent (receiver=0x82077b0, event=0x7fff3656ca60, alienWidget=0x82077b0, nativeWidget=0x594e6c0, buttonDown=0x7ff6c0215b28, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:2967
#18 0x00007ff6bf7e56c8 in QETWidget::translateMouseEvent (this=0x594e6c0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4380
#19 0x00007ff6bf7e3e19 in QApplication::x11ProcessEvent (this=0x7fff3656d5b0, event=0x7fff3656d3d0) at kernel/qapplication_x11.cpp:3513
#20 0x00007ff6bf80abf4 in QEventDispatcherX11::processEvents (this=0x61b8e0, flags=...) at kernel/qeventdispatcher_x11.cpp:132
#21 0x00007ff6c0594292 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#22 0x00007ff6c0594495 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#23 0x00007ff6c059888b in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#24 0x00007ff6b21c2855 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/koffice-2.1.2/krita/main.cc:49
#25 0x0000000000407659 in _start ()

This bug may be a duplicate of or related to bug 227506.

Possible duplicates by query: bug 227506.

Reported using DrKonqi
Comment 1 Cyrille Berger 2011-02-26 18:36:39 UTC
Git commit e6b6a6e7e8a2f678e79f4bdb218e64d26b0a49a3 by Cyrille Berger.
Committed on 26/02/2011 at 18:30.
Pushed by berger into branch 'master'.

Don't show the tone mapping dialog if there are no tone mapping operators available.

BUG:266483

M  +1    -1    krita/plugins/extensions/tonemapping/tonemapping.cc     

http://commits.kde.org/calligra/e6b6a6e7e8a2f678e79f4bdb218e64d26b0a49a3
Comment 2 Cyrille Berger 2011-02-26 18:36:39 UTC
Git commit abae4a5a7ff3576366e59b2d0b72c986cc065f49 by Cyrille Berger.
Committed on 26/02/2011 at 18:28.
Pushed by berger into branch 'master'.

Don't add tone mapping operators if the color space they need is not available.

CCBUG: 266483

M  +14   -8    krita/plugins/extensions/tonemapping/lib/kis_tone_mapping_operator.h     

http://commits.kde.org/calligra/abae4a5a7ff3576366e59b2d0b72c986cc065f49