Bug 265219 - Yourls Plugin is broken - claims bad username/passowrd
Summary: Yourls Plugin is broken - claims bad username/passowrd
Status: RESOLVED FIXED
Alias: None
Product: choqok
Classification: Unclassified
Component: general (show other bugs)
Version: 1.0
Platform: Gentoo Packages Linux
: NOR normal with 7 votes (vote)
Target Milestone: ---
Assignee: Mehrdad Momeny
URL:
Keywords:
: 336030 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-02 19:21 UTC by Sandy Dolphinaura
Modified: 2014-12-13 13:48 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 1.5


Attachments
Dirty patch to make it work (917 bytes, patch)
2012-03-08 11:30 UTC, bmarwell+kdebugtracker
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sandy Dolphinaura 2011-02-02 19:21:33 UTC
Version:           1.0 (using KDE 4.6.0) 
OS:                Linux

After setting the URL shortener to "Yourls", Inputting the YOURLS API url, username, and password, Choqok would not shorten the URL, claiming "Invalid Username or Password".

The username/password combination is correct, I used the same combination to login to the YOURLS control panel

Reproducible: Always

Steps to Reproduce:
1. Set url shortener to "yourls"
2. Enter in API URL
3. Enter in username/password
4. Shorten Link

Actual Results:  
KDE showed a notification saying "invalid username or passowrd"

Expected Results:  
URL should have been shortened
Comment 1 tobias 2011-10-18 11:44:21 UTC
I confirm this bug on version 1.1 of Choqok
It does not send the password in the GET request, the field is simply empty (I checked with wireshark)
Comment 2 bmarwell+kdebugtracker 2012-03-08 10:51:26 UTC
Better use a signature token. And I can confirm, it won't work as it is. I checked the server log.
Comment 3 bmarwell+kdebugtracker 2012-03-08 11:30:00 UTC
Created attachment 69364 [details]
Dirty patch to make it work

The "password" variable didn't seem initialized. I copied the init function code to just before the variable is being used.

Works for me, but is not to be merged ;-)
Comment 4 jpope 2013-12-16 04:48:01 UTC
The 'dirty patch' works for me. First time I've seen the yourls plugin actually work. w00t! ;)
Comment 5 Andrea Scarpino 2014-10-28 09:14:05 UTC
*** Bug 336030 has been marked as a duplicate of this bug. ***