Bug 264914 - Launcher appears when application is running after switching virtual desktops or activity
Summary: Launcher appears when application is running after switching virtual desktops...
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-taskbar (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR normal with 21 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 265515 268326 268519 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-31 08:30 UTC by Jimi Smith
Modified: 2011-08-02 20:40 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of the problem (27.58 KB, image/png)
2011-01-31 08:30 UTC, Jimi Smith
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jimi Smith 2011-01-31 08:30:28 UTC
Created attachment 56685 [details]
Screenshot of the problem

Version:           unspecified (using KDE 4.6.0) 
OS:                Linux

Set the task manager to only show tasks from the current desktop. After going from desktop 1 to desktop 2, both the launcher item and the task item are shown. It remains this way even after going back to desktop 1. The same behavior occurs with activities.

Reproducible: Always

Steps to Reproduce:
Set the task manager to only show tasks from the current desktop.
Select "Show laucher when not running" for one of the tasks.
Switch to another virtual desktop.
Switch back.

Actual Results:  
The launcher item and the task item are shown.

Expected Results:  
Only the task item should be shown.

The cause of the problem seems to be in libtaskmanager. It's emitting the itemAdded signal for both the launcher and the task item when virtual desktops or activities are changed. It should only emit the itemAdded signal once.
Comment 1 Dario Andres 2011-02-13 13:34:41 UTC
*** Bug 265515 has been marked as a duplicate of this bug. ***
Comment 2 Dario Andres 2011-03-13 02:28:33 UTC
*** Bug 268326 has been marked as a duplicate of this bug. ***
Comment 3 Anton Kreuzkamp 2011-08-01 14:15:49 UTC
*** Bug 268519 has been marked as a duplicate of this bug. ***
Comment 4 Anton Kreuzkamp 2011-08-02 20:36:28 UTC
Git commit deb6b3ececf1c62eda1a26d0e91b877bee235ba2 by Anton Kreuzkamp.
Committed on 02/08/2011 at 22:04.
Pushed by akreuzkamp into branch 'master'.

On VD- or activity change just add a launcher if it should be shown.
BUG:264914

M  +10   -2    libs/taskmanager/groupmanager.cpp

http://commits.kde.org/kde-workspace/deb6b3ececf1c62eda1a26d0e91b877bee235ba2
Comment 5 Anton Kreuzkamp 2011-08-02 20:40:57 UTC
Git commit e3851ca9dbc417139a9107a6f18fcacd7f0fec0d by Anton Kreuzkamp.
Committed on 02/08/2011 at 22:04.
Pushed by akreuzkamp into branch 'KDE/4.7'.

On VD- or activity change just add a launcher if it should be shown.
BUG:264914

M  +10   -2    libs/taskmanager/groupmanager.cpp

http://commits.kde.org/kde-workspace/e3851ca9dbc417139a9107a6f18fcacd7f0fec0d