Bug 264794 - Localization of "search term" in class RunnerSyntax doesn't work
Summary: Localization of "search term" in class RunnerSyntax doesn't work
Status: RESOLVED FIXED
Alias: None
Product: krunner
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-29 23:13 UTC by Lasse Liehu
Modified: 2011-05-15 20:47 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Add catalog libplasma to krunner (470 bytes, patch)
2011-04-14 00:31 UTC, Lasse Liehu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lasse Liehu 2011-01-29 23:13:45 UTC
Version:           unspecified (using KDE 4.6.0) 
OS:                Linux

In Plasma::RunnerSyntax::searchTermDescription() (kdelibs/plasma/runnersyntax.cpp):
return i18n("search term");

doesn't return the translated string (at least in some cases). The problem is cured if (hackishly) calling KGlobal::locale()->insertCatalog("libplasma") in RunnerSyntax's constructor, so missing catalog seems to be the problem.

RunnerSyntax objects are created in runner plugins, so could it be that the plugins don't have the "libplasma" catalog set by default?

Reproducible: Always

Steps to Reproduce:
Can be seen when bringing up krunner's help while using a language other than en_US (x-test or something). "<search term>" doesn't get translated into "<xxsearch termxx>" (x-test) or "<hakusana>" (fi).
Comment 1 Lasse Liehu 2011-04-14 00:31:07 UTC
Created attachment 58937 [details]
Add catalog libplasma to krunner

Agh, forget what I wrote there. Well, this patch works (tested) and was the best place I found not knowing the code base.
Comment 2 Lasse Liehu 2011-05-15 20:47:29 UTC
Git commit fd7ae565b058e1be75f96b4e23ad2181a05f0d13 by Lasse Liehu.
Committed on 15/05/2011 at 20:46.
Pushed by lliehu into branch 'KDE/4.6'.

Make sure "search term" is localized in krunner

BUG:264794
(cherry picked from commit 9ea90f9bf35899b8183c1bac80b3a4c1805542b5)

M  +1    -0    krunner/main.cpp     

http://commits.kde.org/kde-workspace/fd7ae565b058e1be75f96b4e23ad2181a05f0d13
Comment 3 Lasse Liehu 2011-05-15 20:47:29 UTC
Git commit 9ea90f9bf35899b8183c1bac80b3a4c1805542b5 by Lasse Liehu.
Committed on 15/05/2011 at 20:46.
Pushed by lliehu into branch 'master'.

Make sure "search term" is localized in krunner

BUG:264794

M  +1    -0    krunner/main.cpp     

http://commits.kde.org/kde-workspace/9ea90f9bf35899b8183c1bac80b3a4c1805542b5