Bug 264467 - Blurred picture is displaying.
Summary: Blurred picture is displaying.
Status: VERIFIED FIXED
Alias: None
Product: calligrastage
Classification: Unclassified
Component: filter/pptx (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Ariya Hidayat
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-27 13:22 UTC by swathi
Modified: 2011-08-17 11:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Test data (180.09 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2011-01-27 13:22 UTC, swathi
Details
Screenshot in MS Powerpoint (206.82 KB, image/x-png)
2011-01-27 13:24 UTC, swathi
Details
Screenshot in Calligra Stage (475.90 KB, image/x-png)
2011-01-27 13:24 UTC, swathi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description swathi 2011-01-27 13:22:17 UTC
Created attachment 56498 [details]
Test data

Version: git commit  6ea30bc370b7eb5223e322fc6ee596cee00d19a9
         (using KDE 4.4.3)                
     OS: Kubuntu 10.04

Test data is in MS Powerpoint 2007 format which has picture and text in it.
Open the same document in Calligra Stage, and observe the display of 
Picture.

Expected outcome:
Picture should be displayed clearly.

Actual outcome:
Blurred picture is displaying.
Please check the screenshots attached.
Comment 1 swathi 2011-01-27 13:24:11 UTC
Created attachment 56499 [details]
Screenshot in MS Powerpoint
Comment 2 swathi 2011-01-27 13:24:59 UTC
Created attachment 56501 [details]
Screenshot in Calligra Stage
Comment 3 T Zachmann 2011-03-17 04:13:22 UTC
There is a big black border on the right and left of the image but no blur.
Comment 4 T Zachmann 2011-03-17 04:50:16 UTC

*** This bug has been marked as a duplicate of bug 264471 ***
Comment 5 swathi 2011-03-23 10:17:53 UTC
Bug 264471 describes about the text accross the picture and this bug is about the size of the picture.
Comment 6 LukasT 2011-08-03 15:13:49 UTC
Git commit 87a13b950005a28cba23da34bd98dbbb7b90afbb by Lukáš Tvrdý.
Committed on 03/08/2011 at 17:10.
Pushed by lukast into branch 'master'.

Fix the black border of the image

o make the pixels transparent

BUG:264467
CCBUG:264471

M  +8    -7    filters/libmsooxml/MsooXmlCommonReaderDrawingMLImpl.h

http://commits.kde.org/calligra/87a13b950005a28cba23da34bd98dbbb7b90afbb
Comment 7 swathi 2011-08-17 11:19:59 UTC
Verified in a79f2ea4d8e16e3116759087b65c2938cb8b540c.