Bug 264050 - Copy to local collection from CD creates directory but copies no files
Summary: Copy to local collection from CD creates directory but copies no files
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Transcoding (show other bugs)
Version: 2.4-GIT
Platform: unspecified Linux
: NOR major (vote)
Target Milestone: 2.4.1
Assignee: Amarok Developers
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-01-23 11:02 UTC by charles
Modified: 2011-01-26 00:22 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.4.1


Attachments
Debug output (66.51 KB, text/plain)
2011-01-23 11:02 UTC, charles
Details

Note You need to log in before you can comment on or make changes to this bug.
Description charles 2011-01-23 11:02:10 UTC
Created attachment 56344 [details]
Debug output

Version:           2.4.0 (using KDE 4.5.5) 
OS:                Linux

Select Copy to Local Collection from context menu. Whichever option is picked from the resulting window results in the same radio-button picklist as in previous versions of Amarok ('Available Formats...') then the 'Organize Files' window. After clicking OK here a directory is created correctly in my collection folders, but no files are copied/transcoded and no error message is generated.
Debug output is attached

Reproducible: Always

Steps to Reproduce:
As above

Actual Results:  
Debug log attached
I assume the problem is:
amarok:   [WARNING] [SqlCollectionLocation] An error occurred when copying a file:  "Device does not have read permissions for this account.  Check the read permissions on the device." 
amarok: END__: void Collections::SqlCollectionLocation::slotJobFinished(KJob*) [Took: 0s]
However I can play and read from the CD in Dolphin and in Amarok, and the group/ownership of the device is correct (see below) 

Expected Results:  
Successful transcode (worked before upgrade to 4.5.5 / 2.4.0)

OS: Linux (x86_64) release 2.6.33.7-desktop-2mnb
Compiler: gcc

$ ls -l /dev/sr0
brw-rw----+ 1 root cdrom 11, 0 2011-01-23 09:17 /dev/sr0
$ groups
charles wheel cdrom usb cdwriter audio users
Comment 1 Myriam Schweingruber 2011-01-23 11:45:40 UTC
So you are actually copying from a CD? Then you should not use the option Transcoding but Copy, as ripping needs the audiocd KIO slave which does transcoding already. Please try again and report back.
Comment 2 Valorie Zimmerman 2011-01-23 11:50:38 UTC
I tried copying from a CD as well, and can confirm that while a folder is created, no files are placed inside. Ripping with Soundjuicer did work, so the problem was not with the CD or my equipment.
Comment 3 charles 2011-01-23 12:01:19 UTC
It doesn't seem to make any difference which of the options you pick on the Copy/Transcode/Transcode_with_local_parameters window. In fact, even Cancel brings up the old Available Formats window ??
However, for the record, choosing copy doesn't work, where opening the disc in Dolphin and dragging FLACs to a local directory does, and that presumably also uses the KIO slave?
Comment 4 Myriam Schweingruber 2011-01-23 13:16:05 UTC
Yes, it does, so apparently it has been disabled by the addition of transcoding which is a regression.
Comment 5 Sergey Ivanov 2011-01-25 22:51:12 UTC
Git commit 88ecec723d9a556708eb3331c8bea27c5c9ffd8e by Sergey Ivanov.
Pushed by ivanov into branch 'master'.

Fixed CD copying functionality.
BUG: 264050

M  +1    -0    ChangeLog     
M  +5    -5    src/core-impl/collections/audiocd/AudioCdCollection.cpp     
M  +1    -1    src/core-impl/collections/audiocd/AudioCdCollection.h     
M  +1    -1    src/core-impl/collections/audiocd/AudioCdCollectionLocation.cpp     

http://commits.kde.org/amarok/88ecec723d9a556708eb3331c8bea27c5c9ffd8e