Bug 263653 - JJ: Don‘t apply lanczos filter when window doesn‘t change size in Present Windows Grid
Summary: JJ: Don‘t apply lanczos filter when window doesn‘t change size in Present Win...
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: scene-opengl (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: junior-jobs
Depends on:
Blocks:
 
Reported: 2011-01-19 15:05 UTC by Kai Uwe Broulik
Modified: 2011-04-25 21:33 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Uwe Broulik 2011-01-19 15:05:56 UTC
Version:           unspecified (using KDE 4.5.95) 
OS:                Linux

(Yet another Present Window Grid thing :P)
In KPackagekit you have little progress windows that indicate how a package installation is going on. When triggering the present windows grid this window just gets moved but - it seems at least so - it doesn‘t change its size because it is already so small (when having like 5 windows opened on my 1366x768 notebook there is enough room). But then the Lanczos filter is applied which makes the bigger windows look nice since the text isn‘t pixelated or something but on this small window where you see that filter in 1:1 size it looks bad and makes the text look blurred and blown.

Reproducible: Always
Comment 1 Martin Flöser 2011-03-19 10:33:23 UTC
just needs a check in lanczosfilter.cpp to apply the filter only if xScale <0.95 || yScale < 0.95
Comment 2 Thomas Lübking 2011-04-25 21:33:20 UTC
Git commit dfac51cd19182df3475226ca915bb32aa27e1ca7 by Thomas Lübking.
Committed on 25/04/2011 at 16:30.
Pushed by luebking into branch 'master'.

only use lanczos filter when either direction is scaled below 90%

BUG: 263653

M  +1    -1    kwin/lanczosfilter.cpp     

http://commits.kde.org/kde-workspace/dfac51cd19182df3475226ca915bb32aa27e1ca7