Bug 262865 - me03: Picture at the top of the Excel sheet is not displaying.
Summary: me03: Picture at the top of the Excel sheet is not displaying.
Status: VERIFIED FIXED
Alias: None
Product: calligrasheets
Classification: Unclassified
Component: filter/xls (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Calligra Sheets (KSpread) Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-11 17:00 UTC by swathi
Modified: 2011-12-01 07:50 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot in MS Excel (292.51 KB, image/x-png)
2011-01-11 17:01 UTC, swathi
Details
Screenshot in Calligra Tables (342.34 KB, image/x-png)
2011-01-11 17:02 UTC, swathi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description swathi 2011-01-11 17:00:21 UTC
Version:git commit 5694375f398e19d93f1b06718485cf2bfac44826
         (using KDE 4.4.3)                
     OS:Kubuntu 10.04

Test data is in MS Excel 2003 format, which has picture at the top of the excel sheet.
Test data is there in the below link.
http://www.unescap.org/ttdw/roadsafety/RoadSafetyData_2009/India.xls
Open the same document in Calligra Tables,and check the display of picture.

Actual outcome:
Picture should be displayed.

Expected outcome:
Picture is not displaying
Comment 1 swathi 2011-01-11 17:01:27 UTC
Created attachment 55867 [details]
Screenshot in MS Excel
Comment 2 swathi 2011-01-11 17:02:05 UTC
Created attachment 55868 [details]
Screenshot in Calligra Tables
Comment 3 Inge Wallin 2011-05-16 15:21:17 UTC
This is a filter issue since Tables shows it correctly if the file is converted with OOo.
Comment 4 LukasT 2011-11-21 13:23:33 UTC
Git commit e7b5098d0d77504ed6779f70680d0c8c09c56a4c by Lukáš Tvrdý.
Committed on 21/11/2011 at 13:40.
Pushed by lukast into branch 'tables-filter-fix-pictures-ltvrdy'.

Fix missing images in groups

o use libmso to handle pictures
o fixes missing borders around pictures
o adds features from libmso like black and white mode

Known regressions: exposing more issues with z-index similar to bug 286607,
as z-index is not handled at all in the excel filter.

CCBUG:262865
CCBUG:244862

M  +5    -1    filters/libmso/pictures.cpp
M  +6    -46   filters/tables/excel/import/ExcelImport.cpp
M  +14   -3    filters/tables/excel/import/ODrawClient.cpp
M  +2    -34   filters/tables/excel/import/excelimporttoods.cc
M  +1    -32   filters/tables/excel/sidewinder/cell.cpp
M  +1    -7    filters/tables/excel/sidewinder/cell.h
M  +17   -29   filters/tables/excel/sidewinder/excel.cpp
M  +1    -8    filters/tables/excel/sidewinder/excel.h
M  +11   -15   filters/tables/excel/sidewinder/globalssubstreamhandler.cpp
M  +0    -2    filters/tables/excel/sidewinder/globalssubstreamhandler.h
M  +0    -66   filters/tables/excel/sidewinder/objects.h
M  +1    -26   filters/tables/excel/sidewinder/sheet.cpp
M  +0    -4    filters/tables/excel/sidewinder/sheet.h
M  +13   -0    filters/tables/excel/sidewinder/workbook.cpp
M  +4    -0    filters/tables/excel/sidewinder/workbook.h
M  +4    -12   filters/tables/excel/sidewinder/worksheetsubstreamhandler.cpp

http://commits.kde.org/calligra/e7b5098d0d77504ed6779f70680d0c8c09c56a4c
Comment 5 LukasT 2011-11-23 08:37:32 UTC
Git commit 312d8bd2395d99d98dc226c40eb08574e547d591 by Lukáš Tvrdý.
Committed on 21/11/2011 at 13:40.
Pushed by lukast into branch 'master'.

Fix missing images in groups

o use libmso to handle pictures
o fixes missing borders around pictures
o adds features from libmso like black and white mode

Known regressions: exposing more issues with z-index similar to bug 286607,
as z-index is not handled at all in the excel filter.

CCBUG:262865
CCBUG:244862

M  +5    -1    filters/libmso/pictures.cpp
M  +6    -46   filters/tables/excel/import/ExcelImport.cpp
M  +14   -3    filters/tables/excel/import/ODrawClient.cpp
M  +2    -34   filters/tables/excel/import/excelimporttoods.cc
M  +1    -32   filters/tables/excel/sidewinder/cell.cpp
M  +1    -7    filters/tables/excel/sidewinder/cell.h
M  +17   -29   filters/tables/excel/sidewinder/excel.cpp
M  +1    -8    filters/tables/excel/sidewinder/excel.h
M  +11   -15   filters/tables/excel/sidewinder/globalssubstreamhandler.cpp
M  +0    -2    filters/tables/excel/sidewinder/globalssubstreamhandler.h
M  +0    -66   filters/tables/excel/sidewinder/objects.h
M  +1    -26   filters/tables/excel/sidewinder/sheet.cpp
M  +0    -4    filters/tables/excel/sidewinder/sheet.h
M  +13   -0    filters/tables/excel/sidewinder/workbook.cpp
M  +4    -0    filters/tables/excel/sidewinder/workbook.h
M  +4    -12   filters/tables/excel/sidewinder/worksheetsubstreamhandler.cpp

http://commits.kde.org/calligra/312d8bd2395d99d98dc226c40eb08574e547d591
Comment 6 swathi 2011-12-01 07:50:32 UTC
Verified in 5992551fa6b6bf4e2d716728e086fd48ff905e33 .