Bug 261191 - Bluetooth wizard should register GSM modem to network-manager
Summary: Bluetooth wizard should register GSM modem to network-manager
Status: RESOLVED FIXED
Alias: None
Product: solid
Classification: Frameworks and Libraries
Component: bluetooth-wizard (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR wishlist with 21 votes (vote)
Target Milestone: ---
Assignee: Alex Fiestas
URL:
Keywords:
: 266539 270965 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-12-25 01:00 UTC by Ferry
Modified: 2011-10-08 13:08 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ferry 2010-12-25 01:00:08 UTC
Version:           unspecified (using KDE 4.5.1) 
OS:                Linux

When connecting a GSM over bluetooth modem-manager detect the GSM, however NetworkManager refuses to enable the Mobile Broadband tab so a DUN connection can be made.
syslog shows:
modem-manager	(/org/freedesktop/ModemManager/Modems/0): data port is rfcomm0
NetworkManager[723]	<info> ignoring modem 'rfcomm0' (no associated Bluetooth device)

Note that gnome-bluetooth wizard does exactly this.

As far as I know with KDE we do not have the possibility to add a DUN connection over a bluetooth GSM now.

Merry XMas

Ferry

Reproducible: Always
Comment 1 Andrey Rakhmatullin 2011-01-05 13:16:29 UTC
Now the only option is to use gnome-bluetooth AND network-manager-gnome. Bluedevil doesn't have any DUN support and only nm-applet provides a gnome-bluetooth plugin (which in turn knows only about nm-applet).
Comment 2 Alex Fiestas 2011-01-05 13:50:12 UTC
Hi

This is planned for the next version of NetworManagement, so we'll have this feature soon enough :p

Thanks for the wish.
Comment 3 darkbasic 2011-02-04 18:19:47 UTC
Is there any experimental support in bluedevil git/knetworkmanager git?
Comment 4 Lamarque V. Souza 2011-02-04 20:02:57 UTC
This bluetooth modem thing is very weird.

1. If I do this as root (or normal user) with my cellphone:

evolucao # dbus-send --system --print-reply --dest=org.bluez
/org/bluez/25735/hci0/dev_<cell phone bluetooth MAC> org.bluez.Serial.Connect
string:dun
method return sender=:1.119 -> dest=:1.245 reply_serial=2
   string "/dev/rfcomm0"

The entry /dev/rfcomm0 is not created although the reply says it should have
been created.

2. If I use qdbusviewer as normal user it creates the /dev/rfcomm0 entry and it
works with wvdial but ModemManager ignores /dev/rfcomm0 with no message in
/var/log/messages, just ignores.

3. If I do this as root:

INFO=$(LC_ALL=C sdptool search DUN | awk '/Searching for DUN on / { print $5 }
/Channel:/ { print " "$NF }')
MAC=$(echo $INFO | awk '{ print $1 }')
CHANNEL=$(echo $INFO | awk '{ print $2 }')

mknod --mode=666 /dev/rfcomm0 c 216 0
rfcomm connect 0 $MAC $CHANNEL

It works with both wvdial and ModemManager, and conseguently with Plasma NM. I
can connect with my cellphone and browse the Internet normally. The last weird
thing is that even though everything is working ModemManager does not get the
access technology used, Edge in this case.
Comment 5 Lamarque V. Souza 2011-02-18 21:33:37 UTC
*** Bug 266539 has been marked as a duplicate of this bug. ***
Comment 6 Lamarque V. Souza 2011-04-14 23:38:03 UTC
*** Bug 270965 has been marked as a duplicate of this bug. ***
Comment 7 Lamarque V. Souza 2011-04-24 06:06:52 UTC
Git commit ada07c830485fcda17d12c90d38f1b9f8b06a584 by Lamarque V. Souza.
Committed on 24/04/2011 at 06:01.
Pushed by lvsouza into branch 'master'.

Updates for bluetooth tethering support.

Full support only in KDE SC 4.7.0 because Plasma NM needs Solid 4.7.0 to
detect bluetooth network interfaces. In the mean time Plasma NM will treat
bluetooth network interfaces as gsm network interfaces. I still need to
implement bluetooth tethering for Cdma phones and Gsm/Cdma) Panu.

Without Solid 4.7.0 Plasma NM will not list the bluetooth interface nor
the bluetooth connection, so the only way to connect is setting the
bluetooth connection to autoconnect. There will be no notifications from
knotify either without Solid 4.7.0 and of course interface details tab
will not work because the interface is not listed.

BUG: 203584
CCBUG: 261191
FIXED-IN: 4.7.0

M  +28   -7    applet/interfacedetailswidget.cpp     
M  +4    -2    applet/nmpopup.cpp     
M  +3    -0    backends/NetworkManager/remoteconnection.cpp     
M  +2    -1    kded/service.cpp     
M  +4    -0    libs/internals/uiutils.cpp     
M  +9    -3    libs/service/gsmnetworkinterfaceactivatableprovider.cpp     
M  +3    -0    libs/service/networkinterfaceactivatableprovider.cpp     
M  +4    -1    libs/service/networkinterfacemonitor.cpp     

http://commits.kde.org/networkmanagement/ada07c830485fcda17d12c90d38f1b9f8b06a584
Comment 8 Lamarque V. Souza 2011-04-26 02:12:29 UTC
Soon Bluedevil will be updated to automatically call the wizard. Until then you can use networkmanagement_configshell command to register a bluetooth DUN (dial-up network) connection using the steps in here:

http://lamarque-lvs.blogspot.com/2011/04/plasma-nm-bluetooth-tethering.html
Comment 9 Alex Fiestas 2011-10-08 13:08:27 UTC
This is done now since BlueDevil 1.2 and NetworkManagement 0.9-beta

Thanks for reporting and giving feedback !