Bug 260735 - RDP view dependent on available size
Summary: RDP view dependent on available size
Status: RESOLVED FIXED
Alias: None
Product: krdc
Classification: Unclassified
Component: RDP (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Urs Wolfer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-19 21:14 UTC by deadeyes
Modified: 2012-12-29 16:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.11


Attachments
Patch for making the size dependent on the view window size (1.76 KB, patch)
2010-12-19 21:14 UTC, deadeyes
Details
Make rdp fit to the whole canvas instead of a predetermined size (2.40 KB, patch)
2012-03-11 22:16 UTC, deadeyes
Details
Fit RDP screen to KRDC size (1.83 KB, patch)
2012-12-23 15:57 UTC, Urs Wolfer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description deadeyes 2010-12-19 21:14:45 UTC
Created attachment 55084 [details]
Patch for making the size dependent on the view window size

Version:           unspecified (using KDE 4.4.5) 
OS:                Linux

When opening an RDP connection it always does this in the predefined resolutions: 800x600, 1024x768, ...

While I have seen that this should get solved in the future by freerdp, I wrote a small patch that does exactly this.

Reproducible: Always




This patch adds a general config option.
Do use it together with "Always show tab bar".
Otherwise you will get that the first rdp connection will get a slightly bigger resolution and as soon as you open the second connection you will get scrollbars for the first connection.
Comment 1 deadeyes 2010-12-27 11:52:12 UTC
Any idea if this will be added in the future release?

I think it is a very small patch and make krdc even more productive.
Comment 2 Urs Wolfer 2010-12-27 11:58:34 UTC
Do I get it right that your patch takes the size of the window when the RDP connection gets opened? It does not resize anymore when you resize the KRDC window?!

How will freerdp handle that?

Anyway, we cannot apply such a patch before trunk is open for KDE SC 4.7 features.
Comment 3 deadeyes 2010-12-27 12:43:36 UTC
I have no idea how freerdp will handle that :p there is not alot of information about this so I might have understand it wrong :p.

From what I understand you cannot resize an rdp connection.
So when you resize the Krdc window (let me think of a reason why and when I do this.. never actually, I want the view as big as possible; Anyway, I made a configuration option for people who don't like it ;) )

If I ever resize then I just double click the link again and it reconnects and uses the new view size (so my programs are still running). It would however be possible to make krdc reconnect automatically.

Anyway, using the standard 1024x768, ... resolutions the same issue arises when you resize the window to small... so that shouldn't keep this feature from being added.
Comment 4 Urs Wolfer 2011-01-01 20:54:33 UTC
Okay, thanks for your patch.

One question: why don't you add a new combobox item instead of the checkbox? I think it would fit into the combobox just as "Use current desktop resolution".
Comment 5 deadeyes 2011-01-01 21:04:53 UTC
The item for combobox would only make this change for 1 connection while I use krdc all the time, so I want it as a default for each connection(as I like full usage of the available screen ;) ).
Comment 6 deadeyes 2011-03-07 11:54:39 UTC
I found the option "Resize to fit" in krdc 4.6.1.
Is this the functionality discussed in this "ticket"?

If it is, it does not work for me.

Just checking (I modified my patch to continue working).
Comment 7 deadeyes 2011-05-15 22:06:08 UTC
Is there any chance my fix/feature will ever be include in the source code?
Or is there any chance that the "Resize to fit" will ever work?

I am on 4.6.3 now and still I have to apply this patch myself :S
It is resolved, it is a few lines and I don't see why anybody would be afraid of including it in the sources. (unless you like alot of wasted space on your screen of course).
Comment 8 Urs Wolfer 2011-05-16 07:45:56 UTC
It's not fixed yet, reopen.
Comment 9 deadeyes 2011-05-16 09:49:07 UTC
Please let me know what is still not working so I can make a patch to get this closed and included.
"It is not fixed yet, reopen" doesn't say alot to me.
There is a diff in attachment.
It probably need minor tweeking to get to work against the current working tree.
Comment 10 Urs Wolfer 2011-05-16 10:11:01 UTC
deadeyes: I'm sorry about the delay of resolving this issue. Thanks for your work anyway! I really appreciate any patches for bug reports / wishes.

Since it introduces new user visible text-messages, it needs to wait until trunk is open again (i.e. 4.8).

I will try to apply this patch and test it.
Comment 11 deadeyes 2012-03-11 22:09:54 UTC
So I created another patch..
This time I added an entry to the Resolution dropdown list.
It sets the width and height to 0 (AUTOSIZE).
When the rdp view is opened it uses the size of the current tab space.

When will this finally be included?

I don't care how but it would be great after 2 years that this finally is included in the sources.
Comment 12 deadeyes 2012-03-11 22:16:06 UTC
Created attachment 69517 [details]
Make rdp fit to the whole canvas instead of a predetermined size
Comment 13 Urs Wolfer 2012-12-23 15:57:00 UTC
Created attachment 75980 [details]
Fit RDP screen to KRDC size

Good news!

I have looked into this patch and slighty modified it. I will commit it after the port from rdesktop to freerdp which will be included in the KDE SC 4.11 release.

@deadeyes: Thanks a lot for your patch! :) Sorry, it took quite some time until I had found time to look int it.
Comment 14 Urs Wolfer 2012-12-29 16:25:47 UTC
SVN commit 1330137 by uwolfer:

Add setting to size RDP view fitting into current KRDC size.

Work is based on a patch by deadeyes.


 M  +4 -0      rdphostpreferences.cpp  
 M  +5 -0      rdppreferences.ui  
 M  +11 -2     rdpview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1330137