Bug 259797 - Blurring interferes with the dashboard effect
Summary: Blurring interferes with the dashboard effect
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: effects-various (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-14 02:10 UTC by Nikola Kovacs
Modified: 2011-03-20 13:23 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.6.2


Attachments
output of glxinfo (26.55 KB, text/plain)
2010-12-14 02:10 UTC, Nikola Kovacs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikola Kovacs 2010-12-14 02:10:37 UTC
Created attachment 54528 [details]
output of glxinfo

Version:           unspecified (using KDE 4.5.85) 
OS:                Linux

The blur on plasma works perfectly.
Translucent windows do not get blurred at all.
The blur option of the dashboard plugin works, sort of, for the first time, but then breaks and won't work until I restart compositing or disable and enable the dashboard plugin.

Reproducible: Always

Steps to Reproduce:
1. Activate dashboard plugin, enable "Apply blur effect to background" option.
2. Activate widget dashboard.

The background is blurred, but the rest of the settings are ignored: desaturation, darkening, even animation duration, the blur happens instantly instead of smoothly.

3. Deactivate widget dashboard
4. Activate the widget dashboard again:

Now it darkens and desaturates smoothly, but it doesn't blur.

5. The results will be the same whenever you activate the dashboard after this - it's as if the blur option has been disabled.
6. Restart compositing
7. Go to step 2.

Actual Results:  
Blur in the dashboard plugin works only the first time, after that it's disabled. It also doesn't desaturate and darken the background, and it's not smoothly animated.

Blur on transparent windows doesn't work at all.

On the other hand, blur on plasma tooltips, menus and popups works perfectly.

Expected Results:  
Blur should work all the time. It should also work in together with the desaturation and darkening effect, and it should blur smoothly, respecting the animation duration option.

Transparent windows should be blurred.

I tried all the advanced settings, including disabling functionality checks, but none of that helped. I also tried with a clean kde profile (removed ~/.kde).
I tried running kwin --replace in a terminal, but the only output was this:

kwin(7353) KWin::CompositingPrefs::detectDriverAndVersion: GL vendor is "NVIDIA Corporation" 
kwin(7353) KWin::CompositingPrefs::detectDriverAndVersion: GL renderer is "GeForce 8800 GT/PCI/SSE2" 
kwin(7353) KWin::CompositingPrefs::detectDriverAndVersion: GL version is "3.3.0 NVIDIA 260.19.06" 
kwin(7353) KWin::CompositingPrefs::detectDriverAndVersion: Detected driver "nvidia" , version "260.19.06" 

I've attached the output of glxinfo.
Comment 1 Thomas Lübking 2010-12-14 16:07:19 UTC
First off: please to not collect several bugs in one report - this makes them unnecessarily hard to track.

"Transparent windows should be blurred."
this is a dupe of bug #239980

I've altered the title of the bug to match the outstanding issue.
Comment 2 Nikola Kovacs 2010-12-14 17:38:22 UTC
If I set a window to 80% transparency via the titlebar context menu, or if I move a window and it becomes semitransparent (via the translucency plugin), it's not blurred. Is that bug #239980?
Comment 3 Martin Flöser 2010-12-14 19:13:37 UTC
On Tuesday 14 December 2010 17:38:24 Nikola Kovacs wrote:
>  Is that bug #239980?
Yes it is, please see especially comment 4.
Comment 4 Nikola Kovacs 2010-12-14 19:23:40 UTC
But why shouldn't the blur plugin blur all windows? And why does the description say "Blurs the background behind semi-transparent windows" when it doesn't do that?
Comment 5 Thomas Lübking 2010-12-14 19:48:47 UTC
Performance reasons, got a better explanation text?

Theoretically it would be (easily) possible to add a (3rd party) plugin to enable blurring for all translucent windows - just go for it ;-)
Comment 6 Kai Uwe Broulik 2010-12-16 16:45:19 UTC
I can confirm this. The first time the Dashboard is ever used since system start, the blur is applied. After closing the blur is no longer applied. Only when closing the dashboard while the fade out is occuring the screen appears blurred and then the dashboard is closed.
Comment 7 Martin Flöser 2010-12-18 11:32:16 UTC
Adding dashboard effect expert.

Please keep the discussion to the dashboard topic.
Comment 8 Andreas Kuhl 2010-12-19 12:43:59 UTC
I can confirm that blur works only for the first dashboard activation and prevents other settings from working. I will have a look at this and fix it.

One drawback of the current implementation is that blur does not honor the delay settings at the moment and most probably won't in KDE SC 4.6.
Comment 9 Kai Uwe Broulik 2010-12-20 14:59:40 UTC
I just noticed, when right-clicking a widget (i.e. opening the context menu) the blur effect disappears after a short time.
Comment 10 Alejandro Nova 2011-01-26 13:24:54 UTC
When I enable the dashboard a second time, I can reproduce this bug. When I close the dashboard, before disappearing, blur kicks in and blurs the screen ~300ms.
Comment 11 Kai Uwe Broulik 2011-01-26 13:38:03 UTC
I set animation speed to extremely slow. I triggered the dashboard, the widgets appear and the background greys out, so the initial effect itself works.
Then I exit the dashboard, then suddenly the whole screen gets blurred and this blur fades out together with the dashboard.
Comment 12 Kai Uwe Broulik 2011-02-08 17:04:33 UTC
Just noticed: When you open the dashboard and then right-click and choose Run command from the context menu, the blur effect gets applied but covers KRunner and when you click anywhere (i.e. on a widget or krunner) the blur vanishes.
Comment 13 Martin Flöser 2011-03-20 13:20:24 UTC
Git commit 629e17d18526ccfae3d3579066e8be927a92437d by Martin Gräßlin.
Committed on 20/03/2011 at 13:22.
Pushed by graesslin into branch 'KDE/4.6'.

Fix Blur behind in Dashboard Effect

By making Dashboard Effect a fullscreen effect the blurring got
accidentially broken (blur ignores fullscreen effects). Reenabling
by setting the force blur role on the dashboard window(s).
BUG: 259797
FIXED-IN: 4.6.2

M  +1    -0    kwin/effects/dashboard/dashboard.cpp     

http://commits.kde.org/kde-workspace/629e17d18526ccfae3d3579066e8be927a92437d
Comment 14 Martin Flöser 2011-03-20 13:23:16 UTC
Git commit 6c015d064013fdd04de60cfa2588e28ec976e0a3 by Martin Gräßlin.
Committed on 20/03/2011 at 13:26.
Pushed by graesslin into branch 'master'.

Fix Blur behind in Dashboard Effect

By making Dashboard Effect a fullscreen effect the blurring got
accidentially broken (blur ignores fullscreen effects). Reenabling
by setting the force blur role on the dashboard window(s).

Reapplied commit 629e17d18526ccfae3d3579066e8be927a92437d from KDE/4.6.

CCBUG: 259797

M  +1    -0    kwin/effects/dashboard/dashboard.cpp     

http://commits.kde.org/kde-workspace/6c015d064013fdd04de60cfa2588e28ec976e0a3