Bug 258509 - Crashed while generating the key
Summary: Crashed while generating the key
Status: RESOLVED WORKSFORME
Alias: None
Product: kgpg
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Rolf Eike Beer
URL:
Keywords: investigated, triaged
Depends on:
Blocks:
 
Reported: 2010-12-01 19:39 UTC by Pablo Cabezas
Modified: 2018-10-27 04:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pablo Cabezas 2010-12-01 19:39:51 UTC
Application: kgpg (2.4.60)
KDE Platform Version: 4.5.80 (4.6 Beta1)
Qt Version: 4.7.1
Operating System: Linux 2.6.36-CHAKRA i686
Distribution (Platform): Archlinux Packages

-- Information about the crash:
- What I was doing when the application crashed: The application crashes while generating the encryption key pair.

-- Backtrace:
Application: KGpg (kgpg), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4fb4930 (LWP 3238))]

Thread 2 (Thread 0xb29d5b70 (LWP 3325)):
#0  0xb7875424 in __kernel_vsyscall ()
#1  0xb5e83fa1 in select () from /lib/libc.so.6
#2  0xb613d151 in QProcessManager::run (this=0xb62a7b10) at io/qprocess_unix.cpp:245
#3  0xb60586c1 in QThreadPrivate::start (arg=0xb62a7b10) at thread/qthread_unix.cpp:285
#4  0xb593de60 in start_thread () from /lib/libpthread.so.0
#5  0xb5e8afbe in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb4fb4930 (LWP 3238)):
[KCrash Handler]
#7  0x08aaffd2 in ?? ()
#8  0x080bf5df in QIODevice::write (text=..., process=0x89619f8, isnew=true) at /usr/include/QtCore/qiodevice.h:127
#9  KgpgInterface::sendPassphrase (text=..., process=0x89619f8, isnew=true) at /home/phil/buildroot/desktop-testing/kdeutils/src/kdeutils-4.5.80/kgpg/kgpginterface.cpp:419
#10 0x0807efba in KGpgTransaction::sendPassphrase (this=0x894ed88, text=..., isnew=true) at /home/phil/buildroot/desktop-testing/kdeutils/src/kdeutils-4.5.80/kgpg/transactions/kgpgtransaction.cpp:237
#11 0x0808641c in KGpgGenerateKey::postStart (this=0x894ed88) at /home/phil/buildroot/desktop-testing/kdeutils/src/kdeutils-4.5.80/kgpg/transactions/kgpggeneratekey.cpp:111
#12 0x0807fd89 in KGpgTransactionPrivate::slotProcessStarted (this=0x894ed88, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfa3e70c)
    at /home/phil/buildroot/desktop-testing/kdeutils/src/kdeutils-4.5.80/kgpg/transactions/kgpgtransaction.cpp:152
#13 KGpgTransaction::qt_metacall (this=0x894ed88, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfa3e70c)
    at /home/phil/buildroot/desktop-testing/kdeutils/src/kdeutils-4.5.80/kgpg/kgpgtransaction.moc:90
#14 0xb616672c in QMetaObject::metacall (object=0x894ed88, cl=QMetaObject::InvokeMetaMethod, idx=9, argv=0xbfa3e70c) at kernel/qmetaobject.cpp:237
#15 0xb6177577 in QMetaObject::activate (sender=0x89619f8, m=0xb62a49a8, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3272
#16 0xb60f1cf7 in QProcess::started (this=0x89619f8) at .moc/debug-shared/moc_qprocess.cpp:128
#17 0xb60f2100 in QProcessPrivate::_q_startupNotification (this=0x8a88000) at io/qprocess.cpp:1072
#18 0xb60f8d8e in QProcess::qt_metacall (this=0x89619f8, _c=QMetaObject::InvokeMetaMethod, _id=12, _a=0xbfa3e938) at .moc/debug-shared/moc_qprocess.cpp:113
#19 0xb642ed6a in KProcess::qt_metacall (this=0x89619f8, _c=QMetaObject::InvokeMetaMethod, _id=20, _a=0xbfa3e938) at /home/phil/buildroot/desktop-testing/kdelibs/src/build/kdecore/kprocess.moc:69
#20 0x080c81ac in KLineBufferedProcess::qt_metacall (this=0x89619f8, _c=QMetaObject::InvokeMetaMethod, _id=20, _a=0xbfa3e938)
    at /home/phil/buildroot/desktop-testing/kdeutils/src/kdeutils-4.5.80/kgpg/klinebufferedprocess.moc:74
#21 0x080c77fc in GPGProc::qt_metacall (this=0x89619f8, _c=QMetaObject::InvokeMetaMethod, _id=20, _a=0xbfa3e938)
    at /home/phil/buildroot/desktop-testing/kdeutils/src/kdeutils-4.5.80/kgpg/gpgproc.moc:73
#22 0xb616672c in QMetaObject::metacall (object=0x89619f8, cl=QMetaObject::InvokeMetaMethod, idx=20, argv=0xbfa3e938) at kernel/qmetaobject.cpp:237
#23 0xb6177577 in QMetaObject::activate (sender=0x886aad0, m=0xb62a67d0, local_signal_index=0, argv=0xbfa3e938) at kernel/qobject.cpp:3272
#24 0xb61c9c63 in QSocketNotifier::activated (this=0x886aad0, _t1=19) at .moc/debug-shared/moc_qsocketnotifier.cpp:89
#25 0xb617e687 in QSocketNotifier::event (this=0x886aad0, e=0xbfa3ede4) at kernel/qsocketnotifier.cpp:317
#26 0xb66d98f1 in QApplicationPrivate::notify_helper (this=0x863f460, receiver=0x886aad0, e=0xbfa3ede4) at kernel/qapplication.cpp:4445
#27 0xb66dedfe in QApplication::notify (this=0x8637780, receiver=0x886aad0, e=0xbfa3ede4) at kernel/qapplication.cpp:4410
#28 0xb72de26a in KApplication::notify (this=0x8637780, receiver=0x886aad0, event=0xbfa3ede4) at /home/phil/buildroot/desktop-testing/kdelibs/src/kdelibs-4.5.80/kdeui/kernel/kapplication.cpp:311
#29 0xb615f6bb in QCoreApplication::notifyInternal (this=0x8637780, receiver=0x886aad0, event=0xbfa3ede4) at kernel/qcoreapplication.cpp:732
#30 0xb619004a in QCoreApplication::sendEvent (source=0x863d1c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 socketNotifierSourceDispatch (source=0x863d1c0) at kernel/qeventdispatcher_glib.cpp:110
#32 0xb56cbb72 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#33 0xb56cc350 in ?? () from /usr/lib/libglib-2.0.so.0
#34 0xb56cc604 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#35 0xb619055c in QEventDispatcherGlib::processEvents (this=0x8600c20, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#36 0xb6799645 in QGuiEventDispatcherGlib::processEvents (this=0x8600c20, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#37 0xb615e069 in QEventLoop::processEvents (this=0xbfa3f064, flags=...) at kernel/qeventloop.cpp:149
#38 0xb615e30a in QEventLoop::exec (this=0xbfa3f064, flags=...) at kernel/qeventloop.cpp:201
#39 0xb6163e7f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#40 0xb66d76c7 in QApplication::exec () at kernel/qapplication.cpp:3719
#41 0x080ba686 in main (argc=9224, argv=0x0) at /home/phil/buildroot/desktop-testing/kdeutils/src/kdeutils-4.5.80/kgpg/main.cpp:57

Reported using DrKonqi
Comment 1 Rolf Eike Beer 2011-02-22 19:38:34 UTC
SVN commit 1222306 by dakon:

transactions: give password entry dialog the correct parent if possible

CCBUG:258509

 M  +14 -9     kgpginterface.cpp  
 M  +2 -1      kgpginterface.h  
 M  +2 -1      transactions/kgpgtransaction.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1222306
Comment 2 Rolf Eike Beer 2011-02-22 19:38:36 UTC
SVN commit 1222307 by dakon:

add a guard around a process when opening passphrase dialog

The process could be deleted meanwhile if the application shuts down or
whatever. Make sure the pointer is still valid when the user finished
the passphrase dialog.

CCBUG:258509

 M  +3 -1      kgpginterface.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1222307
Comment 3 Rolf Eike Beer 2011-02-22 19:39:29 UTC
Please test again with current trunk (or backport those two changes to 4.6 branch).
Comment 4 Andrew Crouthamel 2018-09-22 01:53:06 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Andrew Crouthamel 2018-10-27 04:16:03 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!