Bug 258226 - "Configure Amarok..." menu item disappears in the tray icon menu
Summary: "Configure Amarok..." menu item disappears in the tray icon menu
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.4-GIT
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: 2.4.0
Assignee: Amarok Developers
URL:
Keywords:
: 268762 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-28 22:01 UTC by Alexander Potashev
Modified: 2011-03-18 12:13 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 2.4.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Potashev 2010-11-28 22:01:34 UTC
Version:           2.4-GIT (using KDE 4.5.80) 
OS:                Linux



Reproducible: Always

Steps to Reproduce:
1. run Amarok, start playing a song, quit Amarok
2. run Amarok again, the song should continue playing (you should configure Amarok to do that)
4. open tray icon menu (by clicking RMB), you see the menu item "Configure Amarok..." above the menu items "Quit", "Minimize" and a separator.
5. stop playback, look at the tray icon menu (something changed?), quit Amarok
6. run Amarok again
7. open tray icon menu (by clicking RMB), you don't see the "Configure Amarok..." menu item anymore.



OS: Linux (x86_64) release 2.6.32
Compiler: x86_64-pc-linux-gnu-gcc
Comment 1 Kevin Funk 2011-02-06 03:50:43 UTC
Git commit 65c855efdfd5e74d84627925116cd8f1acf8bc96 by Kevin Funk.
Committed on 06/02/11 at 03:17.
Pushed by kfunk into branch 'master'.

Fix actions getting lost in tray menu.

BUG: 258226

M  +1    -0    ChangeLog     
M  +18   -19   src/TrayIcon.cpp     

http://commits.kde.org/amarok/65c855efdfd5e74d84627925116cd8f1acf8bc96
Comment 2 Nikhil Marathe 2011-03-18 12:13:21 UTC
*** Bug 268762 has been marked as a duplicate of this bug. ***