Bug 256308 - Unable to select multiple packages in Muon
Summary: Unable to select multiple packages in Muon
Status: RESOLVED FIXED
Alias: None
Product: muon
Classification: Applications
Component: muon (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-07 17:35 UTC by Arkadiusz Piekarz
Modified: 2011-01-25 19:18 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arkadiusz Piekarz 2010-11-07 17:35:04 UTC
Version:           unspecified (using KDE 4.5.1) 
OS:                Linux

Muon doesn't allow selecting multiple packages on the list view. This creates serious problems when one wants to do the same action on many packages at once, for instance remove or install them. Because of that, one has to manually repeat the same action for each package.

Reproducible: Always

Steps to Reproduce:
1. Open any list of packages, i.e. All packages.
2. Select one package.
3. Try to add another package to selection, either by holding Ctrl, Shift and clicking on other package, or by holding down left mouse button and dragging the selection. 

Actual Results:  
Only one (or none) package is selected at any time.

Expected Results:  
It should allow selecting multiple packages by using Ctrl, Shift or mouse dragging.

OS: Linux (i686) release 2.6.35-23-generic
Compiler: cc
Muon version 1.0.60
Comment 1 Jonathan Thomas 2010-11-07 18:32:02 UTC
It's on the todo list.
Comment 2 Jonathan Thomas 2011-01-25 19:18:17 UTC
Git commit 86c5a5488bbf0f4adda8b15c3627ae1fe221df07 by Jonathan Thomas.
Pushed by jmthomas into branch 'master'.

Add the ability to mark multiple packages at once via the right-click menu.
It still needs a bit of event compression to speed up the marking of multiple packages. Marking a package is a bit computationally heavy as it is, and without event compression it takes a second or two to mark multiple packages.

FEATURE: 256308

M  +6    -0    libmuon/PackageModel/PackageView.cpp     
M  +2    -0    libmuon/PackageModel/PackageView.h     
M  +167  -0    libmuon/PackageModel/PackageWidget.cpp     
M  +19   -2    libmuon/PackageModel/PackageWidget.h     

http://commits.kde.org/f941090a/86c5a5488bbf0f4adda8b15c3627ae1fe221df07