Bug 255682 - Krita freezes after paste of shape
Summary: Krita freezes after paste of shape
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: General (show other bugs)
Version: git master (please specify the git hash!)
Platform: Compiled Sources Linux
: NOR major
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-30 18:49 UTC by Sven Langkamp
Modified: 2010-12-06 18:43 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Langkamp 2010-10-30 18:49:33 UTC
Version:           svn trunk (using KDE 4.4.5) 
OS:                Linux

Insert a shape, copy and paste it. Application freezes on paste.

Reproducible: Always




OS: Linux (x86_64) release 2.6.32-25-generic
Compiler: cc
Comment 1 Sven Langkamp 2010-11-02 21:31:47 UTC
SVN commit 1192386 by langkamp:

fix pasting for shapes
BUG:255682


 M  +1 -0      kis_shape_controller.cpp  
 M  +0 -7      kis_shape_layer.cc  
 M  +1 -1      kis_shape_layer_paste.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1192386
Comment 2 Dmitry Kazakov 2010-11-05 11:18:54 UTC
SVN commit 1193259 by dkazakov:

A proper fix for bug 255682

The problem was in KoShapePaste, because it performed setParent() and
controller->addShape() calls separately. There is no need to change
Krita's part of shape layers for that (that is why this patch reverts
commit 1192386).

The change to KoShapePaste was approved by Thomas on a mailing list
yesterday.

CCBUG:255682


 M  +0 -1      krita/ui/flake/kis_shape_controller.cpp  
 M  +5 -2      krita/ui/flake/kis_shape_layer.cc  
 M  +1 -1      krita/ui/flake/kis_shape_layer_paste.h  
 M  +4 -3      libs/flake/KoShapePaste.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1193259
Comment 3 Ganesh Paramasivam 2010-12-06 18:43:44 UTC
commit ee4fffe376322ada6b0c64b5813bb882b34d2f4a
branch words-change_tracking-ganeshp
Merge: bf93b5c 5d7f944
Author: Ganesh Paramasivam <ganesh@crystalfab.com>
Date:   Thu Nov 4 16:22:58 2010 +0000

    Merged revisions 1192139,1192147,1192298,1192301,1192306,1192374-1192375,1192386,1192444,1192504,1192572,1192584,1192601,1192603,1192624-1192625,1192627,1192637,1192643,1192649,1192670,1192692,1192710,1192731,1192782,1192785,1193017,1193021,1193045,1193067,1193078 via svnmerge from
    svn+ssh://ganeshp@svn.kde.org/home/kde/trunk/koffice
    
    ........
      r1192139 | danders | 2010-11-02 13:27:58 +0530 (Tue, 02 Nov 2010) | 4 lines
    
      Make material resources always available by default.
      Create material resource if group is material.
      Remove sec/ms from project constraint times.
    ........
      r1192147 | mlaurent | 2010-11-02 14:02:57 +0530 (Tue, 02 Nov 2010) | 2 lines
    
      cmakelint
    ........
      r1192298 | danders | 2010-11-02 19:45:51 +0530 (Tue, 02 Nov 2010) | 2 lines
    
      Fix bug in rcps scheduler when re-scheduling started tasks.
    ........
      r1192301 | danders | 2010-11-02 19:51:12 +0530 (Tue, 02 Nov 2010) | 3 lines
    
      Fix bug in BCWS and index calc when ahead of schedule.
      Don't include material resources in BCWS/BCWP/ACWP calculations.
    ........
      r1192306 | rempt | 2010-11-02 20:48:31 +0530 (Tue, 02 Nov 2010) | 4 lines
    
      Also show openraster thumbnails
    
      Patch by Jon Nordby
      CCMAIl:jononor@gmail.com
    ........
      r1192374 | zachmann | 2010-11-03 00:41:00 +0530 (Wed, 03 Nov 2010) | 6 lines
    
      Optimize styles loading.
    
      Use a shared default style to reduce the number of malloc/free which will
      happen otherwise. This reduces the number of mallocs/frees by 20% the tested
      document.
    ........
      r1192375 | zachmann | 2010-11-03 01:01:08 +0530 (Wed, 03 Nov 2010) | 8 lines
    
      Revert commit 1132942
    
      This introduced a memory leak. I was not able to reproduce the problem.
      If someone can see problems that drop caps show wrong characters in drop caps,
      please send me the document so the correct solution can be found if the problem
      still exists.
    ........
      r1192386 | langkamp | 2010-11-03 02:02:21 +0530 (Wed, 03 Nov 2010) | 3 lines
    
      fix pasting for shapes
      BUG:255682
    ........
      r1192444 | vandenoever | 2010-11-03 13:22:33 +0530 (Wed, 03 Nov 2010) | 1 line
    
      Limit the number of backtraces that is being recorded.
    ........
      r1192504 | vandenoever | 2010-11-03 15:12:14 +0530 (Wed, 03 Nov 2010) | 1 line
    
      Compile fix.
    ........
      r1192572 | ingwa | 2010-11-03 16:07:14 +0530 (Wed, 03 Nov 2010) | 2 lines
    
      Add calls (un)setWindowViewport to more places that need them.
    ........
      r1192584 | dfaure | 2010-11-03 17:14:31 +0530 (Wed, 03 Nov 2010) | 2 lines
    
      Fix detection of formulas; make the code a bit more C++; port some printfs to kDebug.
    ........
      r1192601 | vandenoever | 2010-11-03 19:03:47 +0530 (Wed, 03 Nov 2010) | 1 line
    
      Fix script by explicitly using maxbackgraces as a global variable.
    ........
      r1192603 | dfaure | 2010-11-03 19:13:53 +0530 (Wed, 03 Nov 2010) | 2 lines
    
      Fix parsing (but not handling yet) of shared formulas; remove some sscanf; fix some "???" in the debug output (SkipEmptyParts missing)
    ........
      r1192624 | breitmeyer | 2010-11-03 20:50:17 +0530 (Wed, 03 Nov 2010) | 5 lines
    
      fixed an invalid write on caused by deleting stuff after aquiring the
      iterator and use him after deleting.
    
      fixed the Excelimport sheetreplacement function
    ........
      r1192625 | breitmeyer | 2010-11-03 20:52:55 +0530 (Wed, 03 Nov 2010) | 4 lines
    
      fixed not correctly set category axes, if the selection is not set
      correctly, and this should make no difference, if the plotarea
      proxymodel gets a category data set it should be set in any case
    ........
      r1192627 | ingwa | 2010-11-03 21:01:08 +0530 (Wed, 03 Nov 2010) | 4 lines
    
      Fix the calculation of the World Transform for WMF just like it
      previously was fixed for EMF.
    ........
      r1192637 | dfaure | 2010-11-03 21:51:13 +0530 (Wed, 03 Nov 2010) | 3 lines
    
      * Implement support for shared formulas; skip value, keep only the formula.
      * The look ahead for long lines was skipping lines, device.setPos() doesn't work as expected in qt4, due to buffering (in qtextstream?).
    ........
      r1192643 | dfaure | 2010-11-03 22:03:11 +0530 (Wed, 03 Nov 2010) | 2 lines
    
      Convert formula arguments so that the formulas actually work
    ........
      r1192649 | dfaure | 2010-11-03 22:26:43 +0530 (Wed, 03 Nov 2010) | 4 lines
    
      - remove hardcoded locale
      - add big TODO: formula adjustment. No idea how to do this, it needs some help from kspread code probably.
         For now I'm just dragging formulas by hand after conversion.
    ........
      r1192670 | dfaure | 2010-11-03 23:48:48 +0530 (Wed, 03 Nov 2010) | 2 lines
    
      Fix fallback code, this was obviously messed up by a non-careful search/replace.
    ........
      r1192692 | dfaure | 2010-11-04 00:31:09 +0530 (Thu, 04 Nov 2010) | 4 lines
    
      Same fix here: the "seek back the iodevice" trick doesn't work anymore in Qt4, use a m_nextPendingLine instead.
        Otherwise some lines from the start_styles section appeared as real paragraph in the converted document.
      Port away from deprecated methods.
    ........
      r1192710 | dfaure | 2010-11-04 01:29:42 +0530 (Thu, 04 Nov 2010) | 3 lines
    
      No early returns in case some attributes are not specified; just skip setting these and keep going.
      This fixes the lack of bold when loading of files generated by applixspread import, with e.g.   <font family="Helvetica" weight="0" bold="yes" />
    ........
      r1192731 | dfaure | 2010-11-04 03:11:15 +0530 (Thu, 04 Nov 2010) | 3 lines
    
      Resurrect the plugin for the properties dialog, and port its factory away from KGenericFactory.
      However it still uses KTar... :/
    ........
      r1192782 | dfaure | 2010-11-04 05:56:23 +0530 (Thu, 04 Nov 2010) | 3 lines
    
      Implement a TODO I added in 2002: port the document-info properties-dialog plugin from KTar to KoStore.
      Made it readonly, and made it 'steal' the KPageDialog pages from KoDocumentInfoDlg.
    ........
      r1192785 | dfaure | 2010-11-04 06:00:29 +0530 (Thu, 04 Nov 2010) | 2 lines
    
      Some porting from KGenericFactory to K_PLUGIN_FACTORY
    ........
      r1193017 | dfaure | 2010-11-04 15:39:07 +0530 (Thu, 04 Nov 2010) | 2 lines
    
      Port to m_service->createInstance, should fix kspread startup
    ........
      r1193021 | scripty | 2010-11-04 15:46:59 +0530 (Thu, 04 Nov 2010) | 1 line
    
      SVN_SILENT made messages (.desktop file)
    ........
      r1193045 | dfaure | 2010-11-04 16:44:21 +0530 (Thu, 04 Nov 2010) | 2 lines
    
      The factory should not be part of libkofficecore, it conflicts with the part factories!
    ........
      r1193067 | dkazakov | 2010-11-04 18:23:46 +0530 (Thu, 04 Nov 2010) | 9 lines
    
      Fixed a crash due to calls to projection->set{X,Y}()
    
      We can't adjust projection's offset on every call to
      KisSafeProjection::getDeviceLazy() because other threads may *write*
      to this device at the same time. So we adjust its shift only once,
      that is on projection's initialization.
    
      BUG:255617
    ........
      r1193078 | danders | 2010-11-04 19:22:53 +0530 (Thu, 04 Nov 2010) | 2 lines
    
      Chart: show correct label colors also when cost is disabled.
    ........
    
    svn path=/branches/work/koffice-change-tracking/; revision=1193102