Bug 255106 - Hiding panels gets blurred only after the showing animation is finished
Summary: Hiding panels gets blurred only after the showing animation is finished
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: effects-various (show other bugs)
Version: unspecified
Platform: Debian unstable Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-24 13:55 UTC by ultr
Modified: 2011-12-10 23:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ultr 2010-10-24 13:55:12 UTC
Version:           unspecified (using KDE 4.5.1) 
OS:                Linux

Hiding panel gets blurred only after the showing animation is finished.

It should be animated with blur effect already visible.

Reproducible: Always

Steps to Reproduce:
1) activate Blur effect
2) set the panel to hide itself
3) move the mouse to the edge of the screen to show the panel

Actual Results:  
No blur effect until the panel is fully shown.

Expected Results:  
Blur effect should be visible during the whole animation.
Comment 1 Martin Flöser 2010-12-16 07:12:08 UTC
Probably nothing we can do about it. It's quite difficult to blur the window while it is animated (tried it) and would very likely be very bad from a performance perspective.
Comment 2 Martin Flöser 2010-12-18 13:07:31 UTC
Changing to wishlist as it's currently intended behavior
Comment 3 Martin Flöser 2011-12-10 21:41:56 UTC
Git commit cd78335fef23c290a09fec29d7d9600f0076d63a by Martin Gräßlin.
Committed on 10/12/2011 at 22:32.
Pushed by graesslin into branch 'master'.

Blur behind sliding popups

Finally it is possible :-) If it causes an impact on performance
during the release candidates I'm going to revert.
REVIEW: 103375
BUG: 255106
FIXED-IN: 4.8.0

M  +10   -3    kwin/effects/blur/blur.cpp
M  +14   -1    kwin/effects/slidingpopups/slidingpopups.cpp

http://commits.kde.org/kde-workspace/cd78335fef23c290a09fec29d7d9600f0076d63a
Comment 4 ultr 2011-12-10 23:35:39 UTC
Great. Thanks.

If it affects the performance, maybe an option to enable this in Blur effect settings could be a nice solution?