Bug 254021 - keyboard plasmoid does not work with neo2 layout
Summary: keyboard plasmoid does not work with neo2 layout
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-misc (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Björn Ruberg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-13 00:34 UTC by Bastian Senst
Modified: 2010-10-16 16:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.6


Attachments
the screenshot pressing CAPS LOCK (63.05 KB, image/png)
2010-10-13 00:34 UTC, Bastian Senst
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bastian Senst 2010-10-13 00:34:42 UTC
Created attachment 52468 [details]
the screenshot pressing CAPS LOCK

Version:           unspecified (using KDE 4.5.2) 
OS:                Linux

The keyboard plasmoid doesn't really work well with the german neo2 layout [1].
The problem is that the neo-layout uses additional modifier keys to get into different layers, for example hold CAPS LOCK and press ”d” results into a “:”.
Neo has the following additional modifiers:
CAPS LOCK, (the button next to enter in the center row)
(the button in the bottom row next to english z [german y] printing <,> and | normally), ALT GR
Additionally it is possible to combine these buttons, press CAPS LOCK, ALT GR and another button.
Well, this does not work with the keyboard plasmoid.
I also attached a screenshot of the plasmoid when holding CAPS LOCK (remember, these are not the buttons which should be there).

[1] http://www.neo-layout.org/

Reproducible: Always
Comment 1 Björn Ruberg 2010-10-14 15:40:15 UTC
Can you help me and exactly specify what I need to change in the keyboard to make it better? I think you want the Caps key to have the same behaviour as the Shift key?
Comment 2 Bastian Senst 2010-10-14 21:14:25 UTC
Well, it would be cool if all the modifier keys (with every keyboard layout) work like the shift key, right. NEO2 is an example for a keyboard layout which defines a lot of modifier keys.
Clicking on the CAPS lock key should for example switch to another layer (like shift does, but shift shifts to another layer). At the moment pressing CAPS results into a “\” being painted, same for the corresponding modifier on the other side.
Comment 3 Björn Ruberg 2010-10-16 16:32:34 UTC
SVN commit 1186466 by ruberg:

BUG: 254021
FIXED-IN: 4.6

Made the caps key a sticky key. This will make layouts working that use the caps key as a normal modifier. Hope that does not cause a regression for others



 M  +1 -1      CapsKey.cpp  
 M  +2 -2      CapsKey.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1186466