Bug 253098 - Amarok mute button resume non-functional
Summary: Amarok mute button resume non-functional
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.4-GIT
Platform: Unlisted Binaries Linux
: NOR normal with 5 votes (vote)
Target Milestone: 2.4.0
Assignee: Amarok Developers
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2010-10-03 09:41 UTC by Texstar
Modified: 2011-01-18 23:57 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.4.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Texstar 2010-10-03 09:41:59 UTC
Version:           2.3.2 (using Devel) 
OS:                Linux

Testing Amarok 2.3.2 with initial KDE 4.5.2 packages along with QT 4.7.0 final results in Amarok mute button to not unmute after selecting it. 


Reproducible: Always

Steps to Reproduce:
Play mp3 song
Click on Amarok mute button to turn off sound
Click on Amarok mute button again to unmute sound


Actual Results:  
Amarok does not unmute music

Expected Results:  
Expecting music volume to be restored.
Comment 1 alexander.julo 2010-11-19 00:04:19 UTC
I can confirm that with 2.4-GIT build today on kde 4.5.3.

Changing the volume revokes the unmute by the way.
Comment 2 Myriam Schweingruber 2010-11-20 18:32:29 UTC
I can't reproduce this here, using the phonon-vlc-backend. Which phonon backend do you both use?
Comment 3 alexander.julo 2010-11-20 18:33:20 UTC
gstreamer backend
Comment 4 Alassane 2010-12-17 18:19:49 UTC
I can reproduce it on amarok 2.4 from git. after clicking on unmuting you have to move the slider before you can hear the sound again. No problems for the sound in the rest of the system
Comment 5 Myriam Schweingruber 2010-12-19 13:31:18 UTC
Alassane: which Phonon backend do you use?
Comment 6 Alassane 2010-12-19 16:16:18 UTC
I use Xine backend
Comment 7 Myriam Schweingruber 2010-12-19 19:06:24 UTC
Thank you for your feedback. Maybe somebody else than me from the Amarok people can reproduce this.
Comment 8 harlequix 2010-12-19 23:19:04 UTC
Had the same problem, but now it is fixed using:
amarok git 20101217
gstreamer phonon-backend 0.1
vlc backend 0.3.1
and xine 0.2.60
Comment 9 Myriam Schweingruber 2010-12-19 23:40:03 UTC
Thank you for the feedback.
Comment 10 ojrajala 2011-01-16 23:16:22 UTC
Bug persists, so not fixed.

KDE 4.6 RC2 (4.5.95) 64bit
Amarok 2.4.0
Linux (x86_64) release 2.6.37-CHAKRA
xine 0.2.60

Steps to reproduce exactly the same.
Comment 11 Myriam Schweingruber 2011-01-17 07:42:13 UTC
Thank you for the feedback, reopening.
Comment 12 Sergey Ivanov 2011-01-17 09:25:13 UTC
commit 6e1339533a1645e0d2a3cff0b5deb7bead20efae
branch master
Author: Sergey Ivanov <123kash@gmail.com>
Date:   Mon Jan 17 11:24:34 2011 +0300

    Fixed Mute button.
    BUG: 253098

diff --git a/ChangeLog b/ChangeLog
index 880aa2d..c886eb6 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -13,6 +13,7 @@ VERSION 2.4.1
       <bhargav.1191@gmail.com>. (BR 248690)
 
   BUGFIXES:
+    * Fixed Mute button. (BR 253098)
     * Fixed issue with Organize collection, which made amarok remove newly copied tracks.
       (BR 263301)
     * Fixed wrong "Configure amarok" action position in tray icon popup menu. (BR 263330)
diff --git a/src/EngineController.cpp b/src/EngineController.cpp
index 8a7f480..fcbf1da 100644
--- a/src/EngineController.cpp
+++ b/src/EngineController.cpp
@@ -724,6 +724,8 @@ void
 EngineController::setMuted( bool mute ) //SLOT
 {
     m_audio.data()->setMuted( mute ); // toggle mute
+    if( !isMuted() )
+        setVolume( m_volume );
 
     AmarokConfig::setMuteState( mute );
     emit muteStateChanged( mute );