Bug 249862 - Hyperlink on picture not loaded
Summary: Hyperlink on picture not loaded
Status: CONFIRMED
Alias: None
Product: calligrasheets
Classification: Unclassified
Component: opendocument (show other bugs)
Version: Git
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Calligra Sheets (KSpread) Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-02 11:21 UTC by Nandita Suri
Modified: 2021-03-09 22:44 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
testdata to be opened in kspread (34.17 KB, application/vnd.oasis.opendocument.spreadsheet)
2010-09-02 11:21 UTC, Nandita Suri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nandita Suri 2010-09-02 11:21:50 UTC
Created attachment 51213 [details]
testdata to be opened in kspread

Version:           svn (Rev: 1170564) (using KDE 4.4.3) 
OS:                Kubuntu 10.04

Test data attached is a valid ods file.

STEPS:
1. Load the attached testdata with kspread.
2. Observe the picture set as hyperlink in the document.

Picture is not displayed in the document if it is set as hyperlink. 
Hyperlink and picture are not being displayed.

EXPECTED OUTCOME:
Picture should be displayed when it is set as hyperlink.
Comment 1 Sebastian Sauer 2011-12-06 04:00:38 UTC
Can still reproduce.
Comment 2 Sebastian Sauer 2011-12-19 03:10:00 UTC
Commit cbfc942698a65 fixes the displaying of the picture. That means that the picture is displayed as expected now. Still to do is to proper evaluate the hyperlink so the object does actions on clicking it. Changing the summary to reflect the remaining to-do.
Comment 3 Justin Zobel 2021-03-09 22:44:06 UTC
Thank you for the bug report.

As this report hasn't seen any changes in 5 years or more, we ask if you can please confirm that the issue still persists.

If this bug is no longer persisting or relevant please change the status to resolved.