Bug 249457 - Re-opening a closed tab should restore tab position
Summary: Re-opening a closed tab should restore tab position
Status: RESOLVED FIXED
Alias: None
Product: rekonq
Classification: Unclassified
Component: general (show other bugs)
Version: 0.5.80
Platform: openSUSE RPMs Linux
: NOR wishlist (vote)
Target Milestone: 2.0
Assignee: Andrea Diamantini
URL:
Keywords:
: 303355 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-08-29 22:09 UTC by Todd
Modified: 2012-12-11 16:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Todd 2010-08-29 22:09:36 UTC
Version:           0.5.80 (using KDE 4.5.0) 
OS:                Linux

When I re-open a closed tab, the tab is always placed at the end of the list of tabs.  I think it would be better if it was placed in the same position it was in before it was closed.

Reproducible: Didn't try
Comment 1 Andrea Diamantini 2010-08-31 18:06:17 UTC
How can we guess its position? If it were the 7th and now you have 3 tabs open, what should we do? If you moved tabs how can we guess your will?
Comment 2 Todd 2010-08-31 19:23:06 UTC
Firefox doesn't seem to have a problem with it.
Comment 3 Todd 2010-08-31 19:39:49 UTC
It seems firefox just restores the tab to the same numerical position it had when it was closed, or the end of the tab list if that position was greater than the current number of open tabs.  This seems to work well enough, it may not be perfect but it seems better to me than the current system of just sticking them on the end.  This is especially true if you just want to re-open a tab you accidentally closed.
Comment 4 Andrea Diamantini 2011-12-01 06:51:38 UTC
Understood. Let's see what I can do for 0.9...
Comment 5 Andrea Diamantini 2012-01-29 09:38:32 UTC
Uhm... nothing. Targetting 0.10, sorry. It will be in the first development week for 0.10.
Comment 6 Andrea Diamantini 2012-06-13 10:53:10 UTC
We couldn't reach this in time for 1.0, sorry. In fact it's needed a complete review of our tab management code base to reach this. It has been planned for next development period.
Comment 7 Andrea Diamantini 2012-12-02 09:08:45 UTC
*** Bug 303355 has been marked as a duplicate of this bug. ***
Comment 8 Andrea Diamantini 2012-12-02 10:46:42 UTC
You'll find this fixed in the upcoming 2.0
Comment 9 Andrea Diamantini 2012-12-11 16:51:50 UTC
Git commit 8ebc401712fd157030a485f38d4500543a013cd0 by Andrea Diamantini.
Committed on 02/12/2012 at 11:44.
Pushed by adjam into branch 'first-half-rekonq2-to-master'.

Restore tab position on reopening

M  +1    -0    src/tabhistory.h
M  +16   -4    src/tabwindow/tabwindow.cpp

http://commits.kde.org/rekonq/8ebc401712fd157030a485f38d4500543a013cd0