Bug 248690 - JJ: Missing tooltips in the Settings menu
Summary: JJ: Missing tooltips in the Settings menu
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.3.1-GIT
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: 2.4.0
Assignee: Amarok Developers
URL:
Keywords: junior-jobs
: 266992 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-08-22 12:34 UTC by Myriam Schweingruber
Modified: 2011-02-25 10:25 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.4.1


Attachments
Add a tooltip for General -> Enable context applets collapse animations .. (764 bytes, patch)
2011-01-14 19:56 UTC, Bhargav Mangipudi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Myriam Schweingruber 2010-08-22 12:34:25 UTC
The following tooltips are missing in the Settings menu:

General section:

* Automatically retrieve cover art
* Automatically scroll playlist to current track
* Moodbar style dropdown menu

Playback section:

* Fadeout on stop

Notifications section:

* Use On-Screen Display
* Translucent
* Use custom colors
* Use system notifications

Database section:

all tooltips are missing
Comment 1 Myriam Schweingruber 2010-08-22 13:20:43 UTC
Please refer here for the missing tooltip text:

http://userbase.kde.org/Amarok/Manual/ConfiguringAmarok#Configuring_Amarok
Comment 2 Myriam Schweingruber 2010-08-22 15:15:37 UTC
I will add those once string freeze is over.
Comment 3 Myriam Schweingruber 2010-08-22 15:16:22 UTC
hm, wrong action, sorry for the noise
Comment 4 Michael 2011-01-13 17:59:00 UTC
All the items in comment #0 appear to be fixed in git.

A new missing tooltip has appear, however:
General -> Enable context applets collapse animations
Comment 5 Bhargav Mangipudi 2011-01-14 19:56:02 UTC
Created attachment 56019 [details]
Add a tooltip for General -> Enable context applets collapse animations ..

The patch contains the code for adding tooltip for General -> Enable context applets collapse animations.
Comment 6 Myriam Schweingruber 2011-01-15 10:36:54 UTC
Thank you for the patch, Bhargav. Please submit it to http://git.reviewboard.kde.org (you need to create an identity in http://identity.kde.org before).
Comment 7 Bhargav Mangipudi 2011-01-15 12:19:01 UTC
Patch submitted to reviewboard. http://git.reviewboard.kde.org/r/100393/
Comment 8 Mark Kretschmann 2011-01-16 10:31:38 UTC
commit 240f617283e74c9324fea8fa3c8dbb8aa2dd343c
branch master
Author: Mark Kretschmann <kretschmann@kde.org>
Date:   Sun Jan 16 10:29:12 2011 +0100

    Add missing tooltip for animation settings.
    
    Patch by Bhargav Mangipudi <bhargav.1191@gmail.com>.
    
    BUG: 248690

diff --git a/ChangeLog b/ChangeLog
index c13d326..57b2fce 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -7,6 +7,8 @@ VERSION 2.4.1
   FEATURES:
 
   CHANGES:
+    * Added missing tooltip for animation settings. Patch by Bhargav Mangipudi
+      <bhargav.1191@gmail.com>. (BR 248690)
 
   BUGFIXES:
     * Fixed minor inconsistency in the Collection view. Patch by 
diff --git a/src/configdialog/dialogs/GeneralConfig.ui b/src/configdialog/dialogs/GeneralConfig.ui
index f1625c9..14b2d63 100644
--- a/src/configdialog/dialogs/GeneralConfig.ui
+++ b/src/configdialog/dialogs/GeneralConfig.ui
@@ -64,6 +64,12 @@
       </item>
       <item row="3" column="0">
        <widget class="QCheckBox" name="kcfg_AnimateAppletCollapse">
+       <property name="toolTip">
+         <string>Check to enable animations when context applets collapse.</string>
+       </property>
+       <property name="whatsThis">
+         <string>Check to enable animations when context applets collapse.</string>
+       </property>
         <property name="text">
          <string>Enable context applets collapse animations</string>
         </property>
Comment 9 Myriam Schweingruber 2011-02-25 10:25:13 UTC
*** Bug 266992 has been marked as a duplicate of this bug. ***