Bug 248594 - unit converter crashes plasma if no internet connection and currency is chosen
Summary: unit converter crashes plasma if no internet connection and currency is chosen
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-misc (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-21 13:41 UTC by Johannes Maier
Modified: 2012-01-13 15:04 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Maier 2010-08-21 13:41:02 UTC
Version:           unspecified (using KDE 4.4.2) 
OS:                Linux

unit converter crashes (or better blocks) plasma for a long timeout time if no internet connection is avaliable and currency is chosen. I think the programmer should ping the server used first... This is a really annoying bug since it is such a useful plasmoid.

Another suggestion: It would be nice if one had a switcher button to switch the sides in this calculator if one want to convert something back.

Would it also be possible to have the option to show the result (and maybe also the input) in scientific or engineering notation?

It would also be nice to have also mili inces.

Thank you

Reproducible: Always


Actual Results:  
After some minutes the system (plasma) becomes reactive again...
Comment 1 Petri Damstén 2010-10-11 09:11:29 UTC
- It uses Solid to determine if there are network connection. If there are network connection but not internet connection it can block and ping would probably block too. This needs some work in kunitconversion library.
- In current svn you can edit right editbox and conversion goes to left and vice versa. No switcher button needed.
Comment 2 Petri Damstén 2010-10-11 09:19:49 UTC
SVN commit 1184644 by pdamsten:

Add Mil:
http://en.wikipedia.org/wiki/Mil_%28unit_of_length%29
BUG: 248594

 M  +1 -1      converter.h  
 M  +7 -0      length.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1184644
Comment 3 Christoph Feck 2010-10-11 11:30:35 UTC
The commit probably did not fix this bug, but a different. Please check.
Comment 4 Thijs 2012-01-13 15:04:08 UTC
I cannot confirm this anymore in 4.7.4; without a network connection, it tells me that 1 Euro is equal to 1e-99 US Dollar (which may be true soon enough). Not exactly pretty, but the bug as it was seems solved to me. But feel free to tell me otherwise :)