Bug 247536 - Hyperlink inside the table can not be activated.
Summary: Hyperlink inside the table can not be activated.
Status: VERIFIED FIXED
Alias: None
Product: kword
Classification: Unclassified
Component: general (show other bugs)
Version: git
Platform: Unlisted Binaries Linux
: NOR wishlist (vote)
Target Milestone: Persona: Matt
Assignee: Thomas Zander
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-12 17:54 UTC by Nandita Suri
Modified: 2011-02-28 09:36 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
testdata to be opened in kword (23.00 KB, application/msword)
2010-08-12 17:54 UTC, Nandita Suri
Details
koconverter converted testdata (3.22 KB, application/x-zip-compressed)
2010-08-16 09:27 UTC, Nandita Suri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nandita Suri 2010-08-12 17:54:16 UTC
Created attachment 50072 [details]
testdata to be opened in kword

Version:           svn (Rev: 1161612) (using KDE 4.4.3) 
OS:                Kubuntu 10.04

Testdata having the issue is attached.

STEPS:
1.Open the document with kword.
2.Click on the hyperlink inside the table.

Hyperlinks inside the table are not activated. Nothing happens
on clicking the link.

EXPECTED OUTCOME:
Hyperlink inside the table should be activated once clicked on it. 
Web browser should be launched showing the correct page.
Comment 1 Nandita Suri 2010-08-12 17:56:53 UTC
Converted the testdata attached to an .odt file using koconverter.
OOwriter loads the testdata file as expected and hyperlink is active (launches browser with correct page).

Guessing to be a koffice core problem.
Comment 2 Thomas Zander 2010-08-15 10:16:14 UTC
Please attach the odt document if you are reporting issues where the filter has no relevance.
Comment 3 Nandita Suri 2010-08-16 09:27:21 UTC
Created attachment 50603 [details]
koconverter converted testdata
Comment 4 Nandita Suri 2010-08-16 09:27:54 UTC
(In reply to comment #2)
> Please attach the odt document if you are reporting issues where the filter has
> no relevance.

Attached the required converted odt document.
Comment 5 Thomas Zander 2010-08-16 10:32:59 UTC
Is this table specific? Or do links not work elsewhere either?
Comment 6 Nandita Suri 2010-08-16 10:45:40 UTC
(In reply to comment #5)
> Is this table specific? Or do links not work elsewhere either?

Hyperlinks work in the word documents. The problem is seen in table specific case.
Comment 7 Thomas Zander 2010-08-16 10:51:47 UTC
Thanks for the extra info; please be careful with the other fields they were lost :) Restoring 'wishlist' and 'milestone'.
Comment 8 Camilla Boemann 2010-11-04 18:36:57 UTC
SVN commit 1193118 by boemann:

Fix clicking on text where there is a preceding line to the left of the line
you click. Before the cursor was placed in the preceding line.

Manifestations of this bug are:
* not possible to click in hyperlinks at the top of a table bug:247536
* not possible to click place cursor to the right of shapes with text
  around both sides
* and obviously hyperlinks to the right of such shapes wouldn't have worked
  either

BUG:247536



 M  +20 -6     KoTextDocumentLayout.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1193118
Comment 9 swathi 2011-02-28 09:36:26 UTC
Verified in git commit 604c1940e690f2d163db9083abf7fb58e3f4b1fe.