Bug 245147 - Screensaver continues to run after screen is unlocked
Summary: Screensaver continues to run after screen is unlocked
Status: RESOLVED FIXED
Alias: None
Product: kscreensaver
Classification: Unclassified
Component: locker (show other bugs)
Version: unspecified
Platform: Debian unstable Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kscreensaver bugs tracking
URL:
Keywords:
: 214288 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-07-19 17:05 UTC by Thomas Fjellstrom
Modified: 2010-10-23 19:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.5.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Fjellstrom 2010-07-19 17:05:25 UTC
Version:           unspecified (using KDE 4.4.4) 
OS:                Linux

After unlocking my laptop, the screensaver continues to run. It also leaks pixmaps, but thats another bug report.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
I tried to reproduce, but the screen saver won't come back when I try to lock/unlock again. I had to kill the screensaver because it was leaking pixmaps.
Comment 1 Oswald Buddenhagen 2010-08-03 10:12:06 UTC
there is a chance that this is a dupe of bug #243067. please valgrind it.
Comment 2 Oswald Buddenhagen 2010-10-23 15:19:13 UTC
i notice that the kde screensavers are rather tenacious - they indefinitely spit out X errors after the locker window has gone - i obviously need to fix that.

but you observed a bit more ... i think that was bug 245329
Comment 3 Oswald Buddenhagen 2010-10-23 16:02:28 UTC
SVN commit 1188958 by ossi:

exit on x error if parent process is gone

this condition most likely means that our parent forgot to kill us (or
crashed in the worst case) and we are now trying to render to an
unexisting window, which floods the session log with errors.

FIXED-IN: 4.5.3
BUG: 245147

the bug as a whole may or may not be fixed ...



 M  +18 -0     main.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1188958
Comment 4 Oswald Buddenhagen 2010-10-23 19:38:03 UTC
*** Bug 214288 has been marked as a duplicate of this bug. ***