Bug 244538 - Option to reverse Recent Documents sort
Summary: Option to reverse Recent Documents sort
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-lancelot (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Ivan Čukić
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-13 22:12 UTC by Todd
Modified: 2010-11-06 12:36 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Todd 2010-07-13 22:12:32 UTC
Version:           unspecified (using Devel) 
OS:                Linux

Currently in Lancelot the Recent Documents list is sorted from oldest to newest, so newer files appear on the bottom.  I personally prefer to have the newest files at the top, both because I think newer files should be featured more prominently and also so I don't have to scroll to see more recently-used files.  I suppose the easiest would be to just have an option in the right-click menu (there is already a special one for that section), although having an icon at the top of the list to click might also work.

Reproducible: Always
Comment 1 Ivan Čukić 2010-07-30 00:08:06 UTC
I will not be an option, but yes, the sorting should be new-on-top
Comment 2 Ivan Čukić 2010-11-06 12:36:57 UTC
SVN commit 1193568 by ivan:

- FolderModel sorting - time, name, dirsfirst, reversed flags supported
- Recent documents sorted by time, most recent first
- Sorting by name in shelf

BUG: 244538
BUG: 248318



 M  +1 -1      applets/lancelot/parts/PartsMergedModel.cpp  
 M  +145 -27   libs/lancelot-datamodels/FolderModel.cpp  
 M  +13 -11    libs/lancelot-datamodels/FolderModel.h  
 M  +1 -1      libs/lancelot-datamodels/NewDocuments.cpp  
 M  +3 -3      libs/lancelot-datamodels/RecentDocuments.cpp  
 M  +1 -1      libs/lancelot-datamodels/SystemServices.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1193568