Bug 244352 - kspread:msoffice2007:Spacing between the text in the cells is not retained
Summary: kspread:msoffice2007:Spacing between the text in the cells is not retained
Status: VERIFIED FIXED
Alias: None
Product: calligracommon
Classification: Unclassified
Component: filters (show other bugs)
Version: unspecified
Platform: Unlisted Binaries All
: NOR normal (vote)
Target Milestone: ---
Assignee: Calligra Bugs
URL:
Keywords: reproducible
Depends on:
Blocks:
 
Reported: 2010-06-01 13:24 UTC by Lassi Nieminen
Modified: 2011-12-20 15:02 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
testdata to be opened in kspread (7.70 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2010-06-01 13:24 UTC, Lassi Nieminen
Details
screenshot of the document in kspread (209.85 KB, image/png)
2010-06-01 13:27 UTC, Lassi Nieminen
Details
screenshot of the document in msexcel (120.67 KB, image/png)
2010-06-01 13:31 UTC, Lassi Nieminen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Faure 2010-07-12 17:57:56 UTC


---- Reported by lassi.ta.nieminen@nokia.com 2010-06-01 14:24:41 +0300 ----

Created an attachment
testdata to be opened in kspread

SOFTWARE VERSION:
  Kubuntu 9.10
  Koffice (svn version 1132665)
  Test document (MS Excel 2007): me07_spacing_before after line.xlsx


STEPS LEADING TO THE PROBLEM:
  1. Open the attached document in MSOffice.
  2. Open the same document in KOffice.
  3. Observe the spacing between the text in the cell.

EXPECTED OUTCOME:
  kspread should be able to retain the spacing between the text in cells
  of the document.


ACTUAL OUTCOME:
   kspread is unable to retain the spacing between the text in  the cells 
   of the document-

FREQUENCY:
  Always



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-06-01 14:27:03 +0300 ----

Created an attachment
screenshot of the document in kspread



---- Additional Comments From lassi.ta.nieminen@nokia.com 2010-06-01 14:31:21 +0300 ----

Created an attachment
screenshot of the document in msexcel



--- Bug imported by faure@kde.org 2010-07-12 17:57  ---

This bug was previously known as _bug_ 171806.

Imported an attachment (id=48905)
Imported an attachment (id=48906)
Imported an attachment (id=48907)
Comment 1 Sebastian Sauer 2011-12-09 10:58:49 UTC
Fixed with commit ba9423147279cd. Note that the reason why display more space on the top of the cell then Excel does is that the row has a fixed height and the text in the cell is aligned to the bottom. Since we are needing lesser space to display the same text we earn some additional free space at the top. This is not a bug.
Comment 2 swathi 2011-12-20 15:02:08 UTC
Verified in b2b29030922345d8e727ed03e80fb77537aece46.