Bug 242703 - Need an opiton to turn off adding space after press Enter.
Summary: Need an opiton to turn off adding space after press Enter.
Status: RESOLVED FIXED
Alias: None
Product: lokalize
Classification: Unclassified
Component: editor (show other bugs)
Version: 1.0
Platform: Archlinux Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Nick Shaforostoff
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-24 17:45 UTC by Chao Feng
Modified: 2011-04-21 18:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chao Feng 2010-06-24 17:45:36 UTC
Version:           1.0 (KDE 4.3) (using KDE 4.4.4) 
OS:                Linux

Some language do not need space between words. For example Chinese.

So everytime I press Enter for a new line, I have to go back and remove the added space automatically.

Can localize have an configuration to turn it off? Thanks.

Reproducible: Always
Comment 1 Nick Shaforostoff 2011-04-15 00:07:33 UTC
SVN commit 1227964 by shaforo:

BUG: 242703
disable autoadding space on Enter key press for chinese because it doesnt use spaces as European langs do.

anybody knows other languages that don't use space?



 M  +14 -2     xlifftextedit.cpp  
 M  +1 -0      xlifftextedit.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1227964
Comment 2 Alexander Potashev 2011-04-21 18:19:12 UTC
"anybody knows other languages that don't use space?" -- I think, you should ask this question in the kde-i18n-doc mailing list.