Bug 242501 - Build plug-in should allow to interrupt the building
Summary: Build plug-in should allow to interrupt the building
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-22 17:52 UTC by Oliver Sander
Modified: 2010-10-31 16:47 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Change a menu item name from 'Break' to 'Stop' (1.29 KB, patch)
2010-10-27 18:18 UTC, Oliver Sander
Details
Updated patch (1.52 KB, patch)
2010-10-27 21:16 UTC, Oliver Sander
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Sander 2010-06-22 17:52:10 UTC
Version:           unspecified (using KDE 4.4.4) 
OS:                Linux

I use Kate and the build plug-in to develop C++ programs.  Every now and then, after having triggered 'make' through the plug-in, I realize that I have called make for the wrong target, or in the wrong directory.  I would then like to kill the make process and start it again.  However, this doesn't seem possible from within Kate.

Reproducible: Always
Comment 1 Oliver Sander 2010-10-27 18:17:35 UTC
As it turns out this feature exists, and I just didn't see it.

Part of the reason why I didn't see it is that its menu entry is called 'Break', which, particularly in its German translation 'Pause', made me think of a temporary suspension rather than an actual kill of the build process.  (Of course you may ask why one would ever want to temporarily suspend build processes...)

I tried writing a patch that renames the menu entry from 'Break' to 'Stop'.  Unfortunately I seem to miss something and the menu entry disappears completely rather than switching name.

Could somebody please either review my patch and tell me what I did wrong, or just close this bug if renaming is considered undesirable?  Thanks!
Comment 2 Oliver Sander 2010-10-27 18:18:58 UTC
Created attachment 52913 [details]
Change a menu item name from 'Break' to 'Stop'

Incomplete patch
Comment 3 Milian Wolff 2010-10-27 20:39:57 UTC
Try to increase the version of the .ui file (at the top of it). If that does not work, try to remove ~/.kde/share/apps/kate/plugins/katebuild/ui.rc and restart kate.
Comment 4 Oliver Sander 2010-10-27 21:15:17 UTC
Increasing the version did the trick.  Thanks!
Comment 5 Oliver Sander 2010-10-27 21:16:30 UTC
Created attachment 52918 [details]
Updated patch
Comment 6 Dominik Haumann 2010-10-27 23:06:10 UTC
committed the fix: Build plug-in should allow to interrupt
    
Thanks for the patch, Oliver! Please keep it up.
Comment 7 Christoph Cullmann 2010-10-31 16:47:29 UTC
SVN commit 1191599 by cullmann:

dhaumann:
    fix: Build plug-in should allow to interrupt
    
    Thanks for the patch, Oliver! Please keep it up.

    Other part of patch got commited by me in other commit

BUG: 242501


 M  +2 -2      ui.rc  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1191599