Bug 240912 - action activated for previous content
Summary: action activated for previous content
Status: RESOLVED FIXED
Alias: None
Product: klipper
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Esben Mose Hansen
URL:
Keywords:
: 126221 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-06 17:14 UTC by Oswald Buddenhagen
Modified: 2011-10-23 11:59 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.7.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oswald Buddenhagen 2010-06-06 17:14:16 UTC
Version:           unspecified (using Devel) 
OS:                Linux

when i already have an url in the selection (from xterm) and then cut some text with shift-del (not ctrl-x!) (from konvi's input line), klipper pops up the action menu for the url once i release the shift key.

replay actions on selection from history is on,
ignore selection is off,
selection/clipboard synchronization is off.


Reproducible: Always
Comment 1 Oswald Buddenhagen 2010-08-05 01:18:35 UTC
i just noticed that the just cut text also doesn't appear in the clipboard history, which explains why the last content is reactivated.
Comment 2 Oswald Buddenhagen 2011-07-17 16:46:13 UTC
fixed in master. will backport to 4.7 as soon as tagging freeze is over.
Comment 3 Oswald Buddenhagen 2011-07-28 06:39:26 UTC
Git commit d56a398e87fdd55530fe4971510245e430dda0c3 by Oswald Buddenhagen.
Committed on 17/07/2011 at 18:28.
Pushed by ossi into branch 'KDE/4.7'.

apply selection delay hack only to selection changes

BUG: 240912
FIXED-IN: 4.7.1

M  +1    -1    klipper/klipper.cpp

http://commits.kde.org/kde-workspace/d56a398e87fdd55530fe4971510245e430dda0c3
Comment 4 Oswald Buddenhagen 2011-10-23 11:59:08 UTC
*** Bug 126221 has been marked as a duplicate of this bug. ***