Bug 237821 - mark invisible unicode chars, i.e thin no breaking space or soft hyphen
Summary: mark invisible unicode chars, i.e thin no breaking space or soft hyphen
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Unspecified
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-16 14:24 UTC by Robert Riemann
Modified: 2013-12-31 12:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Riemann 2010-05-16 14:24:53 UTC
Version:            (using KDE 4.4.3)

Please make these special space-like unicode chars visible, i.e. like it oowriter does by adding a gray background:

- mark no breaking space
- thin no breaking space
- soft hyphen

There might be some more chars.
Comment 1 Erlend Hamberg 2010-06-27 07:54:29 UTC
i hadn't seen this bug. as you already have seen non-breaking spaces are now marked. i'll have a look at the rest after the summer if no one else picks it up. :)
Comment 2 Erlend Hamberg 2010-12-23 20:47:34 UTC
i don't really know what to do with this bug. i had a stab at marking narrow non-breaking spaces and soft hyphens in august and picked it up again now. the problem is that Qt draws continuous text in both cases, so it's difficult to mark these so that they are actually visible.

(i tried a grey “dash” for soft hyphen, but it will drown in the two characters, an open box under a narrow nbsp is also almost invisble.)
Comment 3 Michal Humpula 2013-12-31 12:20:37 UTC
Git commit 65d0c80eea6db8df936bd522d0b3d361a524559c by Michal Humpula.
Committed on 31/12/2013 at 12:19.
Pushed by michalhumpula into branch 'frameworks'.

add menu action to display non-printable spaces
Related: bug 85321, bug 312192

M  +1    -0    part/data/katepartui.rc
M  +50   -0    part/render/katerenderer.cpp
M  +16   -0    part/render/katerenderer.h
M  +11   -0    part/view/kateview.cpp
M  +2    -0    part/view/kateview.h

http://commits.kde.org/kate/65d0c80eea6db8df936bd522d0b3d361a524559c