Bug 235760 - KDevelop shows nothing for incorrect watches instead of warning message
Summary: KDevelop shows nothing for incorrect watches instead of warning message
Status: RESOLVED FIXED
Alias: None
Product: kdevelop
Classification: Unclassified
Component: CPP Debugger (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-29 22:15 UTC by Valentyn Pavliuchenko
Modified: 2012-01-15 17:30 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Valentyn Pavliuchenko 2010-04-29 22:15:26 UTC
Version:           4.0 (using KDE 4.4.2)
Compiler:          4.4.3 20100108 
OS:                Linux
Installed from:    Debian testing/unstable Packages

If you add an incorrect watch in the debugger, it will have no value. It confuses users.
Correct behavior: show an error message about bad watch. 
At least: "error: bad expression". Smth more informative will be better.
Comment 1 Andreas Pakulat 2010-04-29 22:34:39 UTC
I have to wonder wether maybe the problem is with gdb not telling us the watch is invalid.
Comment 2 Valentyn Pavliuchenko 2010-04-30 08:54:15 UTC
I'll try to obtain some extra information about the issue.
Comment 3 Niko Sams 2012-01-15 17:30:47 UTC
Git commit b38a89dbac2cb790992a5d0574f528b680acc73d by Niko Sams.
Committed on 15/01/2012 at 18:04.
Pushed by nsams into branch '4.3'.

show error in variables view when gdb returns an error

don't use the returned msg from gdb as it has no real value
and refers to implementation details
("-var-create: unable to create variable object")

M  +5    -5    debuggers/gdb/gdbvariable.cpp

http://commits.kde.org/kdevelop/b38a89dbac2cb790992a5d0574f528b680acc73d