Bug 232628 - crash on startup in RatingWidget
Summary: crash on startup in RatingWidget
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Tags-Rating (show other bugs)
Version: 1.2.0
Platform: Compiled Sources Unspecified
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
: 237979 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-03-29 23:49 UTC by Will Stephenson
Modified: 2017-08-14 21:22 UTC (History)
24 users (show)

See Also:
Latest Commit:
Version Fixed In: 1.3.0


Attachments
New crash information added by DrKonqi (20.55 KB, text/plain)
2010-05-05 20:36 UTC, Fenix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Will Stephenson 2010-03-29 23:49:24 UTC
Version:            (using Devel)
Installed from:    Compiled sources

Crashes just after displaying the album contents on startup.  1.2.0 on KDE 4.4.2.

Backtrace follows

==2493== Thread 1:
==2493== Invalid read of size 8
==2493==    at 0xA2D9401: QTimeLine::stop() (qtimeline.h:139)
==2493==    by 0x6DD13B: Digikam::RatingWidget::setFadingValue(int) (ratingwidget.cpp:170)
==2493==    by 0x6BB034: Digikam::ImageRatingOverlay::slotEntered(QModelIndex const&) (imageratingoverlay.cpp:126)
==2493==    by 0x76255F5: Digikam::AbstractWidgetDelegateOverlay::qt_metacall(QMetaObject::Call, int, void**) (imagedelegateoverlay.moc:151)
==2493==    by 0x6BB66F: Digikam::ImageRatingOverlay::qt_metacall(QMetaObject::Call, int, void**) (imageratingoverlay.moc:74)
==2493==    by 0xA38D78E: QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (qobject.cpp:3293)
==2493==    by 0x9581A74: QAbstractItemView::entered(QModelIndex const&) (in /usr/lib64/libQtGui.so.4.6.2)
==2493==    by 0x6A851A: Digikam::ImageCategorizedView::slotDelayedEnter() (imagecategorizedview.cpp:408)
==2493==    by 0x6AA28B: Digikam::ImageCategorizedView::qt_metacall(QMetaObject::Call, int, void**) (imagecategorizedview.moc:107)
==2493==    by 0x692E8F: Digikam::DigikamImageView::qt_metacall(QMetaObject::Call, int, void**) (digikamimageview.moc:113)
==2493==    by 0xA38D78E: QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (qobject.cpp:3293)
==2493==    by 0xA38A3E2: QObject::event(QEvent*) (qobject.cpp:1212)
==2493==  Address 0x8 is not stack'd, malloc'd or (recently) free'd
==2493== 
KCrash: Application 'digikam' crashing...


Thread 1 (Thread 0x7f9e61f4c860 (LWP 1373)):
[KCrash Handler]
#5  d_func (this=<value optimized out>) at tools/qtimeline.h:139
#6  QTimeLine::stop (this=<value optimized out>) at tools/qtimeline.cpp:723
#7  0x00000000006dd13c in Digikam::RatingWidget::setFadingValue (this=0xe3fc30, value=255) at /usr/src/debug/digikam-1.2.0/digikam/ratingwidget.cpp:170
#8  0x00000000006bb035 in Digikam::ImageRatingOverlay::slotEntered (this=0xe3f320, index=...) at /usr/src/debug/digikam-1.2.0/digikam/imageratingoverlay.cpp:126
#9  0x00007f9e5f4a15f6 in Digikam::AbstractWidgetDelegateOverlay::qt_metacall (this=0xe3f320, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffd3407730)
    at /usr/src/debug/digikam-1.2.0/build/digikam/imagedelegateoverlay.moc:151
#10 0x00000000006bb670 in Digikam::ImageRatingOverlay::qt_metacall (this=0x0, _c=255, _id=14764688, _a=0xfffffffffff6938a) at /usr/src/debug/digikam-1.2.0/build/digikam/imageratingoverlay.moc:74
#11 0x00007f9e5c6c678f in QMetaObject::activate (sender=0xd32470, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0xfffffffffff6938a) at kernel/qobject.cpp:3293
#12 0x00007f9e5d773a75 in QAbstractItemView::entered(QModelIndex const&) () from /usr/lib64/libQtGui.so.4
#13 0x00007f9e5d777f28 in ?? () from /usr/lib64/libQtGui.so.4
#14 0x00007f9e5d77f158 in QAbstractItemView::mouseMoveEvent(QMouseEvent*) () from /usr/lib64/libQtGui.so.4
#15 0x00007f9e5d796ce1 in QListView::mouseMoveEvent(QMouseEvent*) () from /usr/lib64/libQtGui.so.4
#16 0x00007f9e5f4ac73c in KCategorizedView::mouseMoveEvent (this=0x0, event=0xff) at /usr/src/debug/digikam-1.2.0/libs/widgets/common/kcategorizedview.cpp:1121
#17 0x00007f9e5f480098 in Digikam::DCategorizedView::mouseMoveEvent (this=0xd32470, event=0x7fffd3408970) at /usr/src/debug/digikam-1.2.0/libs/widgets/common/dcategorizedview.cpp:597
#18 0x00007f9e5d2afdcf in QWidget::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#19 0x00007f9e5d6545b6 in QFrame::event(QEvent*) () from /usr/lib64/libQtGui.so.4
#20 0x00007f9e5d783a6b in QAbstractItemView::viewportEvent(QEvent*) () from /usr/lib64/libQtGui.so.4
#21 0x00007f9e5f482d0f in Digikam::DCategorizedView::viewportEvent (this=0xd32470, event=0x7fffd3408970) at /usr/src/debug/digikam-1.2.0/libs/widgets/common/dcategorizedview.cpp:704
#22 0x00007f9e5c6b2d97 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0xdd6af0, event=0x7fffd3408970) at kernel/qcoreapplication.cpp:819
#23 0x00007f9e5d259dec in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#24 0x00007f9e5d260bdb in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#25 0x00007f9e5deed456 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#26 0x00007f9e5c6b398c in QCoreApplication::notifyInternal (this=0x7fffd3409690, receiver=0xdd6af0, event=0x7fffd3408970) at kernel/qcoreapplication.cpp:704
#27 0x00007f9e5d25fdb6 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib64/libQtGui.so.4
#28 0x00007f9e5d2df765 in ?? () from /usr/lib64/libQtGui.so.4
#29 0x00007f9e5d2de47a in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/libQtGui.so.4
#30 0x00007f9e5d308932 in ?? () from /usr/lib64/libQtGui.so.4
#31 0x00007f9e5576adee in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#32 0x00007f9e5576e7b8 in ?? () from /usr/lib64/libglib-2.0.so.0
#33 0x00007f9e5576e8e0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#34 0x00007f9e5c6dceb3 in QEventDispatcherGlib::processEvents (this=0xab6500, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#35 0x00007f9e5d30851e in ?? () from /usr/lib64/libQtGui.so.4
#36 0x00007f9e5c6b22a2 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#37 0x00007f9e5c6b267c in QEventLoop::exec (this=0x7fffd34095c0, flags=) at kernel/qeventloop.cpp:201
#38 0x00007f9e5c6b63cb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#39 0x000000000077d34b in main (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/digikam-1.2.0/digikam/main.cpp:193
Comment 1 caulier.gilles 2010-03-30 09:42:40 UTC
Marcel, Johannes,

Sound like a problem from model view port. Right?

Gilles Caulier
Comment 2 Johannes Wienke 2010-03-30 13:24:09 UTC
Hm I don't think so. This looks like a crash directly in the rating widget in setFadingValue. Can anything strange happen there if value is 255?
Comment 3 Will Stephenson 2010-03-30 13:37:02 UTC
Last night it just looked like the fading animation had not yet been instantiated when setFadingValue was called from that code path.
Comment 4 Kevin Kofler 2010-03-30 17:58:27 UTC
Changing the if (d->fadingValue >= 255) at digikam/ratingwidget.cpp:168 to if (d->fadingValue >= 255 && d->fadingTimeLine) should fix this crash.
Comment 5 Johannes Wienke 2010-03-30 19:13:16 UTC
*** Bug 232734 has been marked as a duplicate of this bug. ***
Comment 6 Johannes Wienke 2010-03-30 20:13:48 UTC
SVN commit 1109177 by jwienke:

Fix crash in rating widget.

Thanks for the hint.

BUG: 232628

 M  +2 -2      NEWS  
 M  +1 -1      digikam/ratingwidget.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1109177
Comment 7 Julien Narboux 2010-03-31 09:27:51 UTC
What is the impact of this bug ? maybe a 1.2.1 would be nice to have ? because it may take time before the new database features in 1.3.0 branch are stable.
Comment 8 Simone Lazzaris 2010-04-02 13:59:52 UTC
(In reply to comment #7)
> What is the impact of this bug ? maybe a 1.2.1 would be nice to have ? because
> it may take time before the new database features in 1.3.0 branch are stable.

I vote for a 1.2.1! Right now I can't use digikam (without downgrading, that is) and it's one of the my favourite applications - and one of the best features of kde!
Comment 9 Kevin Kofler 2010-04-02 14:31:40 UTC
Just apply this patch:
http://cvs.fedoraproject.org/viewvc/rpms/digikam/devel/digikam-1.2.0-kde232628.patch?revision=1.1&view=markup
or nag your distributor to apply it if you're using binary packages.
Comment 10 Nicolas L. 2010-04-15 20:07:25 UTC
*** Bug 234469 has been marked as a duplicate of this bug. ***
Comment 11 caulier.gilles 2010-04-16 10:10:21 UTC
*** Bug 234516 has been marked as a duplicate of this bug. ***
Comment 12 Nicolas L. 2010-04-17 09:09:59 UTC
*** Bug 234586 has been marked as a duplicate of this bug. ***
Comment 13 Fenix 2010-05-05 20:36:34 UTC
Created attachment 43277 [details]
New crash information added by DrKonqi

Crash. Just open, select an album and open preview or simply wait a few seconds.
Comment 14 caulier.gilles 2010-05-06 08:46:03 UTC
Fenix,

This file is fixed in current code from svn trunk (next digiKam 1.3.0)

Gilles Caulier
Comment 15 Mark Purcell 2010-05-09 14:33:32 UTC
*** Bug 236930 has been marked as a duplicate of this bug. ***
Comment 16 caulier.gilles 2010-05-10 11:45:23 UTC
*** Bug 236989 has been marked as a duplicate of this bug. ***
Comment 17 caulier.gilles 2010-05-10 11:53:11 UTC
*** Bug 236621 has been marked as a duplicate of this bug. ***
Comment 18 caulier.gilles 2010-05-11 09:32:35 UTC
*** Bug 237161 has been marked as a duplicate of this bug. ***
Comment 19 Johannes Wienke 2010-05-17 22:27:11 UTC
*** Bug 237979 has been marked as a duplicate of this bug. ***
Comment 20 caulier.gilles 2010-05-18 09:02:54 UTC
*** Bug 237981 has been marked as a duplicate of this bug. ***
Comment 21 Johannes Wienke 2010-05-23 21:47:30 UTC
*** Bug 238605 has been marked as a duplicate of this bug. ***
Comment 22 caulier.gilles 2010-05-27 05:35:59 UTC
*** Bug 238962 has been marked as a duplicate of this bug. ***
Comment 23 Johannes Wienke 2010-06-02 11:36:10 UTC
*** Bug 240436 has been marked as a duplicate of this bug. ***
Comment 24 Johannes Wienke 2010-08-11 21:02:43 UTC
*** Bug 247413 has been marked as a duplicate of this bug. ***
Comment 25 Marcel Wiesweg 2010-08-12 14:23:28 UTC
*** Bug 246369 has been marked as a duplicate of this bug. ***
Comment 26 Marcel Wiesweg 2010-08-13 11:19:51 UTC
*** Bug 246534 has been marked as a duplicate of this bug. ***
Comment 27 Nicolas L. 2010-08-14 15:55:55 UTC
*** Bug 246846 has been marked as a duplicate of this bug. ***
Comment 28 Nicolas L. 2010-08-14 15:56:06 UTC
*** Bug 246899 has been marked as a duplicate of this bug. ***