Bug 231213 - konqueror needs 2 clicks in a link to go after a search
Summary: konqueror needs 2 clicks in a link to go after a search
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-18 12:12 UTC by
Modified: 2011-02-11 01:04 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.6.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 2010-03-18 12:12:59 UTC
Version:           4.4.1 (KDE 4.4.1) (using 4.4.1 (KDE 4.4.1), Mandriva Linux release 2010.0 (Official) for x86_64)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.31.12-desktop-1mnb

When doing a search, and you click in a search link, konqueror doesnt do anything, you need to click in that link again so that konqueror goes for it.
Comment 1 Thiago Macieira 2010-03-18 12:26:32 UTC
I can confirm this issue on trunk too.

Note that the search that the reporter is talking about is the search field in the Search toolbar.
Comment 2 2010-08-02 23:49:33 UTC
Is it possible to fix this?
Its quite annoying to have to click twice in a link after a search, when using the konqueror search field thats provided by konq-plugins
Comment 3 David Faure 2011-02-04 01:22:49 UTC
Is this because of the completion popup which is sometimes still visible on the search field, at the time of the first click?  (in which case the click simply closes the popup)
Comment 4 Thiago Macieira 2011-02-04 08:36:31 UTC
I don't remember. I only tested this because the reporter insisted that I test.

It's now been one year.

But I don't think it was that mundane.
Comment 5 2011-02-05 04:24:19 UTC
No, this bug isnt related with the suggestions that are popped in the search filed.

This refers to the result of a search that provides severall links, and when clicking in one of those links nothing happens, you need to click twice so that konqueror can go.
Comment 6 David Faure 2011-02-11 01:02:48 UTC
Git commit 713462a0cda593dd2c85bb0c221aba332f84edff by David Faure.
Committed on 11/02/2011 at 00:57.
Pushed by dfaure into branch 'KDE/4.6'.

Fix many problems in the completion box of the searchbar

* clearSuggestions was crashing to due unexpected reentrancy
(takeItem -> currentTextChanged -> textEdited -> clearSuggestions)
BUG: 265484

* completion box would pop up -after- hitting return, so it would eat
the first click in the webpage
BUG: 231213

* pressing the mouse on a suggestion item would also lead to a text change which
would clear suggestions, hard to use; solved by not doing this while the mouse
button is down. This problem still kind of happens with key down/up, but isn't
solvable under the current KLineEdit logic of "choosing text in completion popup
is equivalent to typing it".

M  +27   -12   konq-plugins/searchbar/searchbar.cpp     
M  +1    -0    konq-plugins/searchbar/searchbar.h     

http://commits.kde.org/kde-baseapps/713462a0cda593dd2c85bb0c221aba332f84edff