Bug 228325 - Properties dialogue cannot change target of symlink, even though it is editable
Summary: Properties dialogue cannot change target of symlink, even though it is editable
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: SVN
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
: 228657 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-02-24 16:11 UTC by Jonathan Marten
Modified: 2010-03-02 04:32 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Marten 2010-02-24 16:11:43 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

The file properties dialogue (popup menu - Properties) for a symbolic link shows the link target as "Points to".  This field is editable, which would lead the user to suppose that the target of the link could be changed by editing it here and clicking OK.  However, doing this does not change the symlink target on the filesystem.

If changing the symlink target is not intended to work, then the "Points to" field should be read-only to reflect this.
Comment 1 David Faure 2010-02-26 14:38:53 UTC
SVN commit 1096311 by dfaure:

Add missing connection which made the "change link target" feature non-working unless
something else in the dialog was changed too.
BUG: 228325


 M  +1 -0      kpropertiesdialog.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1096311
Comment 2 David Faure 2010-02-26 14:41:58 UTC
SVN commit 1096316 by dfaure:

Backport: Add missing connection which made the "change link target" feature non-working unless
something else in the dialog was changed too.
Fixed for: 4.4.1 (just in time ;)
CCBUG: 228325


 M  +1 -0      kpropertiesdialog.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1096316
Comment 3 Christoph Feck 2010-03-02 04:32:03 UTC
*** Bug 228657 has been marked as a duplicate of this bug. ***