Bug 217711 - Directory chooser dialog in copy/move file does not allow to actually choose a directory
Summary: Directory chooser dialog in copy/move file does not allow to actually choose ...
Status: RESOLVED FIXED
Alias: None
Product: krusader
Classification: Unclassified
Component: general (show other bugs)
Version: 2.4.0-beta3 "Single Step"
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Krusader Bugs Distribution List
URL:
Keywords: reproducible
: 308377 315356 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-12-07 13:38 UTC by Dominik Stadler
Modified: 2018-05-06 00:16 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominik Stadler 2009-12-07 13:38:40 UTC
Version:           2.0.0 (using KDE 4.3.4)
OS:                Linux
Installed from:    Ubuntu Packages

When I choose "copy" or "move" in Krusader I get a dialog where I can enter the directory where to copy/move the files/directories to. There is also a button to use a file dialog to select the target directory. However when I try to use this file dialog, it does not allow me to actually select a directory. 

When I try to select a directory in the list of sub-directories of the current one, this directory is opened, instead of chosen as the selected one. When I try to press "Ok" when I have the correct directory open, nothing happens. So I could not find any way to select a directory with this dialog, is there one?
Comment 1 Jekyll Wu 2012-11-07 01:04:42 UTC
Still reproduciable using 2.4.0-beta3.
Comment 2 Jan Lepper 2013-02-08 19:24:45 UTC
Git commit 7c22649f7d7b7817fb4060858f9c60ef664e5be3 by Jan Lepper.
Committed on 08/02/2013 at 20:23.
Pushed by janlepper into branch 'master'.

FIXED: [ 217711 ] directory chooser dialog does not allow to choose a directory
REVIEW: 107308

set url requester mode to KFile::Directoy in the KChoseDir::getFile() methods
add  KChooseDir::getFile() for the cases where callers expect a file
more copy & paste - this will be cleaned up in krusader-next

M  +1    -0    ChangeLog
M  +33   -0    krusader/Dialogs/krdialogs.cpp
M  +1    -0    krusader/Dialogs/krdialogs.h
M  +2    -2    krusader/Panel/panelfunc.cpp

http://commits.kde.org/krusader/7c22649f7d7b7817fb4060858f9c60ef664e5be3
Comment 3 Jan Lepper 2013-02-08 19:27:59 UTC
*** Bug 308377 has been marked as a duplicate of this bug. ***
Comment 4 Jekyll Wu 2013-02-18 10:07:37 UTC
*** Bug 315356 has been marked as a duplicate of this bug. ***