Bug 215364 - wish that the use of "ctrl+mouse wheel" zoom in and out
Summary: wish that the use of "ctrl+mouse wheel" zoom in and out
Status: RESOLVED FIXED
Alias: None
Product: step
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist with 2 votes (vote)
Target Milestone: ---
Assignee: Sebastian Ziebarth
URL:
Keywords:
: 267075 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-11-20 02:35 UTC by Christian Herzberg
Modified: 2011-05-10 21:40 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Herzberg 2009-11-20 02:35:12 UTC
Version:           0.1.0 (using 4.3.2 (KDE 4.3.2), Debian packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.31-6.slh.2-sidux-686

In Step 0.1.0 the mouse wheel can be used to go up and down. Holding "Alt" in addition move to left and right. Combing the two ways with "Shift" makes the step larger.

Please make "ctrl" in addition to the usage of the mouse wheel to zoom in and out (crtl + Wheel up   = zoom in; 
 crtl + wheel down = zoom out)

Combined with the "shift"-key the step can be larger.

Thanks a lot and best regards
Comment 1 Sebastian Ziebarth 2011-04-08 14:14:44 UTC
*** Bug 267075 has been marked as a duplicate of this bug. ***
Comment 2 Sebastian Ziebarth 2011-05-10 21:40:22 UTC
Git commit dffef9134a558c1659f76eb7d1e93134c458eb24 by Sebastian Vöcking.
Committed on 10/05/2011 at 21:19.
Pushed by voecking into branch 'master'.

Merge branch 'zooming'

FEATURE: 215364

MM +25   -0    step/worldscene.cc     
MM +1    -0    step/worldscene.h     

http://commits.kde.org/step/dffef9134a558c1659f76eb7d1e93134c458eb24