Bug 214352 - Konqueror MediaWiki Printing Artifacts
Summary: Konqueror MediaWiki Printing Artifacts
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 206799 228447 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-11-13 08:25 UTC by Fabian Köster
Modified: 2010-02-27 06:49 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Printout of Wikibooks-page mentioned above (968.87 KB, image/jpeg)
2009-11-13 08:31 UTC, Fabian Köster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Köster 2009-11-13 08:25:57 UTC
Version:            (using KDE 4.3.2)
Compiler:          gcc (Ubuntu 4.4.1-4ubuntu8) 4.4.1 
OS:                Linux
Installed from:    Ubuntu Packages

When I print pages from Mediawiki-Sites (like Wikipedia) I get some strange results (see attached scan).
The page I printed was http://de.wikibooks.org/wiki/Mathematik:_Statistik:_Gemeinsame_Wahrscheinlichkeit_mehrerer_Ereignisse

I am using Kubuntu Karmic and a HP LaserJet 1200 Printer. With Kubuntu Jaunty (KDE 4.2.x) I did not experience such problems.

Also, using rekonq or other WebKit-based browsers the page is printed correctly. So I assume this is related to khtml.
Comment 1 Fabian Köster 2009-11-13 08:31:26 UTC
Created attachment 38294 [details]
Printout of Wikibooks-page mentioned above
Comment 2 Germain Garand 2010-02-12 05:20:36 UTC
SVN commit 1088979 by ggarand:

great, looks like these two Qt regressions have finally been fixed,
so we can enable back the optimized code and close all the printing bugs
that closing/restoring the QPainter triggered

I'll do that in two commits so that problems can be pin-pointed :

1) stop ending the QPainter before painting widgets to buffers,
 it's not needed anymore and Qt has poor support for that.

 Fixes printing on pages with form widgets.

BUG: 197402
BUG: 214352
BUG: 191999

 M  +4 -10     render_replaced.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1088979
Comment 3 Germain Garand 2010-02-24 03:14:48 UTC
SVN commit 1095342 by ggarand:

automatically merged revision 1088979:
great, looks like these two Qt regressions have finally been fixed,
so we can enable back the optimized code and close all the printing bugs
that closing/restoring the QPainter triggered

I'll do that in two commits so that problems can be pin-pointed :

1) stop ending the QPainter before painting widgets to buffers,
 it's not needed anymore and Qt has poor support for that.

 Fixes printing on pages with form widgets.

BUG: 197402
BUG: 214352

 M  +4 -10     render_replaced.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1095342
Comment 4 Germain Garand 2010-02-25 13:46:04 UTC
*** Bug 228447 has been marked as a duplicate of this bug. ***
Comment 5 Germain Garand 2010-02-27 06:49:48 UTC
*** Bug 206799 has been marked as a duplicate of this bug. ***