Bug 209647 - Not handling Daylight Savings Time correctly
Summary: Not handling Daylight Savings Time correctly
Status: RESOLVED FIXED
Alias: None
Product: kstars
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal with 80 votes (vote)
Target Milestone: ---
Assignee: Akarsh Simha
URL:
Keywords:
: 210718 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-10-06 17:38 UTC by David Houlden
Modified: 2011-08-27 21:20 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Houlden 2009-10-06 17:38:57 UTC
Version:           1.5.3 (using KDE 4.3.1)
OS:                Linux

I am in the UK. I have my location set to Cambridge UK. Today, 6th Oct 2009 we have British Summer Time in effect (GMT + 1 hour). I have my PC hardware clock set to local time (BST currently) and my KDE timezone set to London Europe/GB.

When I launch KStars, the local time (LT) shown top left of the screen is always set to GMT, one hour before my local time. If I then go to the settings menu -> Geographic and just click OK the local time displays correctly as BST. This problem also affects the rise and set time of objects on the various displays such as What's Up Tonight.

KStars 1.2.9 on KDE 3.5.10 does not exhibit this problem.
Comment 1 Lukas Middendorf 2009-10-17 15:31:51 UTC
*** Bug 210718 has been marked as a duplicate of this bug. ***
Comment 2 Scott 2009-12-14 14:54:03 UTC
Similar problem here, though I'm in Melbourne AU and have my hardware clock set to UTC. It shows LT one hour behind the correct local time (15 Dec 09) and corrects itself (including repositioning objects) if i go to settings->geographic and press 'ok'.
Comment 3 kjones1200 2010-04-02 14:15:59 UTC
Similar problem here.
I have
Kstars 1.5.3
KDE 4.3.2
Ubuntu (64 bit) 9.10 
Linux version 2.6.31-20-generic (buildd@crested) (gcc version 4.4
.1 (Ubuntu 4.4.1-4ubuntu8) ) #58-Ubuntu SMP Fri Mar 12 04:38:19 UTC 2010 (Ubuntu
 2.6.31-20.58-generic)
If I run the startup-wizard the time is correct until I restart Kstars.
After that is is 1 hour before EDT
System time and location (Utica, NY) have been set.
Comment 4 mxklinger 2010-04-07 19:21:53 UTC
I am seeing the same problem. Apparently the version of kstars I am using still reflects the old US daylight savings time rules, even though I downloaded & installed the "update" referred to in the program's "download new data" option. The sunrise and sunset times, for example, are one hour too early for early April here in Wyoming.
Comment 5 Marco 2010-04-12 13:33:38 UTC
Same problem here with KStars 1.5.3 and KDE 4.3.4.

Just clicking OK in [Settings] -> [Geographic], the local time displays correctly. Quite annoying wiht rise and set times.
Comment 6 Yiannis Belias 2010-04-12 21:09:00 UTC
Marco's tip fixes it until kstars is closed. On startup I have to press OK in [Geographic] again.

KDE 4.3.4, KStars 1.5.3, Kubuntu 9.10 32bit.
[Geographic] set on Athens, Greece, UT+2.00, DST Rule EU.
Kstars is one hour behind local time. This happened when time changed to daylight saving time, seems like Kstars ignores the change from +2.00 to +3.00
Comment 7 step247 2010-04-26 20:12:46 UTC
Same problem in Estonia
Comment 8 Tadas 2010-08-29 20:08:02 UTC
Kstars 1.6.0 in KDE SC 4.5.0 still doesn't respect daylight savings settings on startup. Workaround with [Settings] -> [Geographic] is working, but it's very annoying to do that on every startup.
Comment 9 Tadas 2010-08-29 20:09:46 UTC
*** This bug has been confirmed by popular vote. ***
Comment 10 Marta Rybczyńska 2011-08-13 18:58:07 UTC
Additional workaround:
Edit ~/.kde/share/config/kstarsrc and in the Location section add 
DST=EU
(replace EU with your DST rule code).

Patch submitted to RB.