Bug 209011 - Refinements on the Sortable playlist
Summary: Refinements on the Sortable playlist
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Applications
Component: Playlist (show other bugs)
Version: 2.3-GIT
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: 2.3.1
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-30 18:50 UTC by Augusto Leite
Modified: 2009-12-19 23:33 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Augusto Leite 2009-09-30 18:50:04 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

I found an usability issue when using the new sortable playlist of amarok.


If you have a sorting breadcrumb with more than one level, clicking on the sorting level name, say album, deletes the next sorting level name on the breadcrumb. On the other hand, if you click on the arrow itself ( ^ v ), it sorts descending/ascending. The problem is that that little "blue/focus/glow" on mouse hover surrounds both the sorting level name and the arrow, giving the user the impression of only one action can be done, but actually there are two actions.

My suggestion is to separate these "glow" into two, to really show that in fact there are two "buttons" there.

For instance:
  ----------------------------
 | Album | V | > | Artist | ^ |
  ---------------------------- 

The problem gets even worse if the user is used to the spreadsheet like playlist, because on those type of playlists, clicking on the name of the colums really sorts the content ascending/descending.

Hope I have made myself clear, it is really a hard thing to explain (even worse because English is not my first language).


Great work guys.. amarok is already just the BEST audio player and I know it will be even better in the next releases.. keep up the great work.
Comment 1 Kuba Serafinowski 2009-09-30 19:27:05 UTC
That sounds sane, we should consider that.
Comment 2 Teo Mrnjavac 2009-09-30 21:03:29 UTC
Hello
I'm the dev who mostly created the sorting thing, your point is very valid and I've been aware of the issue from the start. For 2.2 I did what I had the time to do, and usually other, more serious issues took precedence. Also, the fix for this isn't hard but it's definitely not trivial either if we want it to look good, so it needs some time and love.
I agree that this should be done for a post-2.2 release, maybe 2.3 or even 2.2.x.
I'm categorizing this as bug rather than wishlist because I think it's an actual usability bug.
Comment 3 Myriam Schweingruber 2009-11-16 22:25:38 UTC
Teo, is this doable for 2.2.2?
Comment 4 Teo Mrnjavac 2009-11-16 22:52:18 UTC
If someone would like to submit a patch, yes, but I'm trying to graduate in the coming weeks so I don't think I can dig into this for a month or so.
As I said, it's something that needs to be addressed and I've been aware of the issue, but I wouldn't call it critical, and it would take some work and time to do it right.
For 2.2.3 or 2.3 it should be doable.
Comment 5 Teo Mrnjavac 2009-12-19 23:33:17 UTC
commit 7e974a3ffdf267fd6497372a228a6a98ce8cc123
Author: Teo Mrnjavac <teo@getamarok.com>
Date:   Sat Dec 19 23:06:57 2009 +0100

    Enhance playlist breadcrumb sorting buttons hover state, by separately highlighting order arrow primitives.
    BUG: 209011