Bug 208521 - Provide 'Any time' option when deferring alarms
Summary: Provide 'Any time' option when deferring alarms
Status: CLOSED FIXED
Alias: None
Product: kalarm
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Mandriva RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: David Jarvie
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-25 17:52 UTC by Maurice Batey
Modified: 2010-09-02 12:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maurice Batey 2009-09-25 17:52:38 UTC
Version:           2.1.8 (using KDE 4.2.4)
OS:                Linux
Installed from:    Mandriva RPMs

Steps to Reproduce:

1. Set a display 'Any Time' reminder

2. When it eventually displays, at say 12:34, ask it to be deferred to e.g.
   'tomorrow'.
   (It should then be displayed the next day immediately after 'start-of-day'     (00:00 here) or login time, whichever occurs last.

  But it is actually displayed at 12:34, as if 'Any Time' had been replaced by the specific time '12:34'.
Comment 1 David Jarvie 2009-09-25 21:32:13 UTC
Currently the defer dialogue doesn't offer the option of 'any time' - it will defer to the exact date and time shown in the dialogue when you click OK.

For this reason, I'm changing this bug report to a wishlist item, and changing its title accordingly.
Comment 2 Maurice Batey 2009-09-25 22:22:43 UTC
> Currently the defer dialogue doesn't offer the option of 'any time' - it will
> defer to the exact date and time shown in the dialogue when you click OK.

That action is totally illogical! 

What the user is entitled to believe is that the action's specification will not be changed in nature, except for the DATE - as implied by "defer".

  "Defer" means "at a later date", not "change the time-of-day option"....

This report is the recording of a DESIGN/IMPLEMENTATION BUG, not a wish.
Comment 3 David Jarvie 2009-09-25 23:28:45 UTC
I don't see any reason why someone might not want to defer an 'any time' alarm to a specific date and time. It wouldn't be safe to assume that people will always want to defer an 'any time' alarm to another 'any time' date. Yes, it's currently a limitation that you can't defer to 'any time' on a specified date - but that's an additional feature which has so far not been implemented or previously asked for.

To get round this, just set the deferral time to your start-of-day time, and it will work as if 'any time' had been specified (provided the cancel-if-late option doesn't prevent late-triggered deferrals from being displayed).
Comment 4 Maurice Batey 2009-09-26 13:57:12 UTC
> It wouldn't be safe to assume that people will
> always want to defer an 'any time' alarm to another 'any time' date. 

  But that's precisely what *is* assumed!

I was not asking for any additional Any Time' option to be added.

What I am saying is that it is a (dangerous) *error* for KAlarm to CHANGE the 'Any Time' setting to a 'Time' setting, because:

There is a danger of a missed alarm in the current situation. Consider this scenario:

  (1) User sets an 'Any Time' alarm

  (2) On the specified day, the user has logged in late - say 18:00, after which the alarm soon will appear.

  (3) The user does not have time to act upon the alarm, so asks for it to be Deferred until 'tomorrow', when he plans to login early (because he is then soon going out for the rest of the day).
      Like me, he does not realise that Defer will *change* the 'Any Time' setting to 'Time' (e.g. 18:02 in this case) but assumes he will see it as soon as he logs in the next day (because he remembers setting it as 'Any Time').

  (4) The next morning the user logs in at 10:00. But the alarm is not yet shown (because it has been reset to 'Time: 18:02).
      Soon after, the user logs out for the rest of the day.

     SO HE DOES NOT SEE THE DEFERRED ALARM THAT DAY.

That is what is wrong with the current situation. Kalarm is behaving wrongly here.
Comment 5 David Jarvie 2009-09-26 15:45:24 UTC
What if the person wants to defer it by just an hour, say? - the 'any time' option wouldn't be wanted in this case. And regardless, the Defer dialogue displays exactly what time it is being deferred to, so there is no ambiguity.

You're the first person to ask for this option, so it's now in the list of things to do.
Comment 6 Maurice Batey 2009-09-26 17:16:07 UTC
> What if the person wants to defer it by just an hour, say? - the 'any time'
> option wouldn't be wanted in this case.

OK, let's take that case. If - as it should - the Defer options showed the original "Any Time" status of the alarm, then - yes - it would also need to provide a 'Later Today' option where he could choose e.g. "+ 1 hour", or 2,3,4  hours..., or alternatively a precise time. 

> ...the Defer dialogue
> displays exactly what time it is being deferred to, so there is no ambiguity.

  That's for the chosen Defer DAY (tomorrow, next week, or whatever). 
Why on earth would he want to defer to the same arbitrary time when it was last displayed, when it is an 'Any Time' alarm?

The cleanest (and possibly simplest) solution (where the alarm started as an 'Any Time' alarm) might be to show two Defer 'time' alternatives

     (1) "Keep original 'Any Time' setting" (Default)
     (2) "Change from 'Any Time' to a specific display time"

(If he clicks on (2), then show the current time, as at present, so that he can then adjust that time.)

Where the original setting was a specific time, then the two options might instead be shown as:

     (1) "Change to 'Any Time'"
     (2) "Keep the original display time" (Default)

The general rule default should be that the original setting ('Any Time' or specific time) is retained unless the user changes it.
  That is intuitively what a user will assume.


A quick-and-dirty temporary fix would be to add a WARNING to the Defer options:

   "To retain the alarm as 'Any Time', change the above time to '00:00'."
Comment 7 Maurice Batey 2009-09-26 17:31:26 UTC
P.S. 99% of my many alarms are 'Any Time'.

   That's why it is a *pain* to have to manually change the Defer time to "00:00"!
Comment 8 David Jarvie 2009-09-28 16:16:14 UTC
There is now an 'any time' option in the Defer dialogue for date-only alarms. This isn't the default setting - the default still assumes that the alarm is likely to be deferred to a specific date/time. The fix will be in KDE 4.3.2.

SVN commits 1028907, 1028929.
Comment 9 Maurice Batey 2009-09-28 16:21:56 UTC
Great - well done, David!

Hopefully I'll acquire KDE 4.3.2 when I move to Mandriva 2010.0 later this year.

(Then I shall be able to stop having to laboriously enter "00:00" in the time option of Defer - because it ignores "0" as an abbreviation for it!)
Comment 10 Maurice Batey 2009-09-28 16:30:48 UTC
But I still think it's *wrong* to change the 'Any Time' status of the alarm.